form not sending emails

Permalink
just created a fresh install of the latest C5, went to test the submit form and it does not work properly. it creates the record into the viewer from the dashboard but does not send the email. tried a reinstall and still get the same issue..

any suggestions as this used to always work just fine

thanks
matt

View Replies:
hutman replied on at Permalink Reply
hutman
If you look under Logs in the Dashboard does it show a record where it tried to send the email? That would help to determine if the block isn't sending the email or if the server isn't sending the email.
mka replied on at Permalink Reply
Hi Hutman,

I get the following - not sure if it C5 or server related though :(

Mail Exception Occurred. Unable to send mail: Unable to send mail. mail() has been disabled for security reasons
#0 /home/asuva/public_html/aplus/concrete/libraries/3rdparty/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/asuva/public_html/aplus/concrete/libraries/3rdparty/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/asuva/public_html/aplus/concrete/core/helpers/mail.php(368): Zend_Mail->send(NULL)
#3 /home/asuva/public_html/aplus/concrete/core/controllers/blocks/form.php(461): Concrete5_Helper_Mail->sendMail()
#4 /home/asuva/public_html/aplus/concrete/core/models/block.php(411): Concrete5_Controller_Block_Form->action_submit_form()
#5 /home/asuva/public_html/aplus/concrete/startup/process.php(344): Concrete5_Model_Block->passThruBlock('submit_form')
#6 /home/asuva/public_html/aplus/concrete/dispatcher.php(253): require('/home/asuva/pub...')
#7 /home/asuva/public_html/aplus/index.php(2): require('/home/asuva/pub...')
#8 {main}
hutman replied on at Permalink Reply
hutman
This would indicate that your hosting company does not allow the mail function to run on the server that you are hosted on.
Chuy2042 replied on at Permalink Reply
I know this has almost a year but probably someone can find it useful. I am using 5.7.4 (I guess) and I notice that concrete5 send me the test email with no problem but the form did not. This is probably wrong but as a quick fix works. Just enter the block controller and find the send() method, a couple lines before, there is this:

$mh->from( $formFormEmailAddress );

Just delete it. It should be there but it is the one causing problems. ¿Anyone knows Why?
sidon replied on at Permalink Reply
Ok! This issue has almost a year, but can be useful for desperate.

If your ISP is dreamhost, look:http://wiki.dreamhost.com/Sender_Domain_Policy_and_Spoofing#What_is...
surefyre replied on at Permalink Reply
surefyre
Having similar errors in the C5 dash test email page using default PHP setting.

However, doing a normal PHP mail() in my package on_start() works perfectly as a test. Not the webserver or the host's fault, something else...

Any ideas?
surefyre replied on at Permalink Reply
surefyre
Bug submitted, then
surefyre replied on at Permalink Reply
surefyre
For anyone reading this with the same problem I believe I found the fix. Finally.

In my installation, for whatever reason - and this is both dev and live which were both setup as standard C5 installs from 8.2.1 individually - the validation email from and fromname are null and this causes the validation registration email to screw up.

I put this in my package controller to explicitly set the values in C5
//
        // Fix validation email address info cos C5 team forgot to put it in?
        \Config::save('concrete.email.validate_registration.address', '[email protected]');
        \Config::save('concrete.email.validate_registration.name', 'The One Group');


Now it works. I really hope this helps folks with the same issue. Will add it to my bug report.

Now just don't tell the client I spent about a day in total finding this fix...
surefyre replied on at Permalink Reply
surefyre
For anyone reading this with the same problem I believe I found the fix. Finally.

In my installation, for whatever reason - and this is both dev and live which were both setup as standard C5 installs from 8.2.1 individually - the validation email from and fromname are null and this causes the validation registration email to screw up.

I put this in my package controller to explicitly set the values in C5
//
        // Fix validation email address info cos C5 team forgot to put it in?
        \Config::save('concrete.email.validate_registration.address', '[email protected]');
        \Config::save('concrete.email.validate_registration.name', 'The One Group');


Now it works. I really hope this helps folks with the same issue. Will add it to my bug report.

Now just don't tell the client I spent about a day in total finding this fix...