Global changes to page attributes - exclude from sitemap xml

Permalink
Searched for an answer to this in the forums and online but no joy.
Is there a way to globally change page setting for the tickbox 'do not show in sitemap xml'?
Ive gone into page attributes and changed to show on every page but it dosen't tick the boxes.

Global changes like this for attributes would probably make a great feature or add-on.

deanhawthornthwaite
View Replies: View Best Answer
hutman replied on at Permalink Reply
hutman
You can bulk update Page Attributes in the Page Search interface. Depending how many pages you have you might be able to do them all, or you could do them in a few batches.
deanhawthornthwaite replied on at Permalink Reply
deanhawthornthwaite
Hey hutman thanks for your reply.

Sorry but I don't follow what your saying. Could you steer me a bit more please?
hutman replied on at Permalink Best Answer Reply
hutman
Login go to Dashboard -> Sitemap then click on Page Search in the menu, this lists all of the pages on your site. Click on Advanced in the search box, scroll to the bottom and change the number of results to try to get the maximum per page. Click the checkbox in the header row to select all of the records on that page, from the dropdown select Edit Properties and change the attribute.
deanhawthornthwaite replied on at Permalink Reply 1 Attachment
deanhawthornthwaite
Thanks so much for your instructions, i've never used that facility before.
Sadly after ticking all the relevant pages i wanted to change, i got an error saying max 30 seconds execution time exceeded. (see attached)
jasteele12 replied on at Permalink Reply
jasteele12
To get you past this, try selecting fewer pages at a time.

On slower (shared) hosting, you'll want to increase this in your php.ini:
max_execution_time = 120

I've seen installs fail with only 30 seconds on some shared hosts...
deanhawthornthwaite replied on at Permalink Reply
deanhawthornthwaite
thanks jasteele12.

I increased to 120 but still get the error saying 'Maximum execution time of 30 seconds exceeded'. will check with my host in case there is an override somewhere else.
I have previously edited the php.ini file to allow larger uploads so it must be working.
jasteele12 replied on at Permalink Reply
jasteele12
Depending on the hosting, you may either have to kill off (or wait for them to expire) any running PHP (F)CGI processes or restart the Apache service.

You can check the live value: http://yoursite.com/index.php/dashboard/system/environment/info... or create a file called called something like phpinfo.php in your site root with the following:
<?php
phpinfo();
Then browse to http://yoursite.com/phpinfo.php... and verify that the new value is actually 120 - some hosts restrict this value :(

You'll want to delete this file later for possible security reasons.
deanhawthornthwaite replied on at Permalink Reply
deanhawthornthwaite
My hosting provider indicated that I can increase this PHP parameter via cPanel >> Select PHP version >> Switch to PHP Options.

Not sure this would apply for all hosts but for me this worked.
jasteele12 replied on at Permalink Reply
jasteele12
Glad to hear you got it working Dean.