HELP: Website suddenly broken (HTTP ERROR 500)

Permalink
Hi, I have a Website that suddenly stopped working. When trying to reach the site i get following error:

This page isn’t working
localhost is currently unable to handle this request.
HTTP ERROR 500


I cannot access the website or the dashboard. I am also not able to upgrade because the host does not support ssh andhttp://www.yoursite.com/ccm/system/upgrade... also cannot be reached.

I have a second website that is very similar, it was installed at the same time on the same host and still works. I tried to copy the concrete folder of that website and replaced the folder of the broken site, but still get the same error.

Any ideas? What can I do to fix this problem?

# concrete5 Version
Core Version - 5.7.4.2
Version Installed - 5.7.4.2
Database Version - 20150504000000

View Replies: View Best Answer
hutman replied on at Permalink Reply
hutman
Do you have a cpanel somewhere that you can see what the PHP Error log is? Looks like there should be something helpful in there.
nenosw replied on at Permalink Reply
Hi, thanks for your reply. I turned on php error logging and get this:

[21-Nov-2017 16:52:35 Europe/Zurich] PHP Fatal error:  Uncaught TypeError: Argument 1 passed to Whoops\Run::handleException() must be an instance of Exception, instance of ParseError given in /home_pr5/a/p/apotheke-olten.ch/htdocs/homecare-mittelland.ch/concrete/vendor/filp/whoops/src/Whoops/Run.php:229
Stack trace:
#0 [internal function]: Whoops\Run->handleException(Object(ParseError))
#1 {main}
  thrown in /home_pr5/a/p/apotheke-olten.ch/htdocs/homecare-mittelland.ch/concrete/vendor/filp/whoops/src/Whoops/Run.php on line 229
[21-Nov-2017 16:52:35 Europe/Zurich] PHP Parse error:  syntax error, unexpected ''QzozMToiWmVuZFxJMThuXFRyYW5zb' (T_ENCAPSED_AND_WHITESPACE) in /home_pr5/a/p/apotheke-olten.ch/htdocs/homecare-mittelland.ch/application/files/cache/0fea6a13c52b4d47/25368f24b045ca84/38a865804f8fdcb6/57cd99682e939275/8f3a01e2e3b200aa/f980d8ea6abd2ae6/8ef45ae84c9a2610/ba1d7ed81f503d96.php on line 13
[21-Nov-2017 16:52:35 Europe/Zurich] PHP Fatal error:  Exception thrown without a stack frame in Unknown on line 0


UPDATE: posted the wrong error log first
hutman replied on at Permalink Best Answer Reply
hutman
Are you able to delete everything in the application/files/cache directory? It looks like you have an error in your cache file which is causing issues.
nenosw replied on at Permalink Reply
Yes, I deleted everything and get the following error now:

unexpected error
Declaration of Concrete\Core\Permission\Access\EditPagePropertiesPageAccess::save($args) should be compatible with Concrete\Core\Permission\Access\Access::save()
hutman replied on at Permalink Reply
hutman
If you turn on debugging output can you see what file is causing that error?
nenosw replied on at Permalink Reply
OK, i changed the PHP version from 7.0 to 5.6 and now it works again. Thanks a lot.