No input file specified.

Permalink
Hey all

Have tried everything I know how to fix the dreaded "No input file specified" issue. Hosting on Domain Priced Right.

They say FastCGI is turned on but only the index.php page is showing for the sight. http://www.jgintl.com is the web site.

Any ideas?

Bill
bcarone
View Replies:
mkly replied on at Permalink Reply
mkly
I'm sure you have but have you tried?
RewriteRule .* index.php/$1 [L]
bcarone replied on at Permalink Reply
bcarone
My .htaccess is this

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>
mkly replied on at Permalink Reply
mkly
did you try
-NOTE that I'm only changing the RewriteRule

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L]
</IfModule>

or
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^.*$ index.php/$1 [L]
</IfModule>

or
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php/$1 [L]
</IfModule>
bcarone replied on at Permalink Reply
bcarone
Will try them. Thanks
EdwardMartinIII replied on at Permalink Reply
EdwardMartinIII
Hey mkly, thanks for that list! I found what I was looking for in it! Gracias!
stephanebeck replied on at Permalink Reply
stephanebeck
RewriteRule ^(.*)$ index.php?/$1 [L]
worked for me. Thanks mkly, good Karma!
jordanlev replied on at Permalink Reply
jordanlev
This is an annoying problem that comes up alot, and unfortunately there are many different things you need to try because every web host is configured slightly differently.

Here are some links with various approaches:
http://www.concrete5.org/developers/bugs/5-4-1-1/path_info-problem/...
http://jeremeclaussen.com/blog/2010/3/30/concrete5-pretty-urls-and-...
http://www.concrete5.org/community/forums/installation/no-input-fil...
http://www.concrete5.org/community/forums/usage/andquotno_input_fil...

And I recently came across this page which is for wordpress, but it's the same issue and has a bunch of things you can try:
http://codex.wordpress.org/Using_Permalinks...

Good luck.
barefootwitch replied on at Permalink Reply
I'm probably the dumbest person on this forum, but I cannot, for the life of me, find the mystical .htaccess file. I chose Concrete5 because it seemed easy to add pages, etc. Simple HTML I can do, php, not so much. I've googled a lot, but still confused.
bcarone replied on at Permalink Reply
bcarone
Barefootwitch

Often you wont have it there. Most static html sites don't always use them.

Are you having issues as well. I don't know why you would state your not able to find the file.

Welcome to the community by the way. Ask anything you need to have help with.
frz replied on at Permalink Reply
frz
files that start with a period tend to hide on unix platforms. Chances are
it exists but your FTP client isn't showing it. You should explore any
"hide system file" type settings.

best wishes

Franz Maruna
CEO - concrete5.org
http://about.me/frz