Unable to Connect to Community - Blank Screen

Permalink 2 users found helpful
We have a site currently running and are moving to

The site was long ago linked to a Concrete account but it is lost. I delete the records of it by performing:
DELETE from Config where cfKey = 'MARKETPLACE_SITE_TOKEN';
DELETE from Config where cfKey = 'MARKETPLACE_SITE_URL_TOKEN';

I reboot apache and mysql instance and then log-in to try to connect. The space on the page is blank.

I can execute the upgrade process successfully to and then, the page looks the same in all versions.

The screenshot attached is in 5.6 but it looks about the same in each.

1 Attachment

View Replies: View Best Answer
CharismaBusiness replied on at Permalink Reply
I am having the same exact problem as of 1 hr ago... I just installed C5 on a new sub-domain and have never had this issue on any other c5 site.
hurtlecreative replied on at Permalink Reply
I couldn't reconnect after those steps... But after clearing the cache it worked.
iLP replied on at Permalink Best Answer Reply
Running Clean install. Rigid Light theme as only addon.

I, too, experienced this blank screen phenomenon. It happened after installing SSL certificate to my site host, and effectively changing my site to https:// sitewide. c5 then complained that the base URL had changed, but I was unable to change it on either side to accept the new connection to marketplace. I looked in the database Config table, but the marketplace token rows did not exist to be deleted. I disabled and cleared all caches on both client and server sides to no avail.

My solution was as follows:

1. Delete the corresponding Project from my concrete5.
2. View Source code of blank community connect window displayed at Add Functionality link on my site.
3. Search resulting page source for:

4. Click the link contained therein. It looks something like this (i've edited this example for demonstration purposes):
<iframe class="ccm-marketplace-frame-connect" id="ccm-marketplace-frame-14092XXXXXX" frameborder="0" width="100%" height="300" src="http://www.concrete5.org/marketplace/connect/-/register_step1?ts=14092XXXXXX&csiBaseURL=https%3A%2F%2Fwww.example.com&csiURL=https%3A%2F%2Fwww.example.com&csToken=1M6MiFjusMuXXXXXXXXXXXXXXXXXXXXXXXXXTcQQn58fEnazLr5x5CNuj2lBD3vzMNj&csReferrer=https%3A%2F%2Fwww.example.com%2Findex.php%2Fdashboard%2Fextend%2Fconnect%2Fconnect_complete%2F&csName=Your Site Title"></iframe>

5. The successful connection dialog appears above the blank box on your connect to community page on the dashboard.
6. Return to the Add Functionality page on your dashboard and behold.

FWIW, this is what worked for me when the dialog was blank.

sherri333 replied on at Permalink Reply
Thank you for this!
CraigFarr replied on at Permalink Reply
Great solution - Thanks!
designportfolio replied on at Permalink Reply
This also worked for us - thank you
splashby replied on at Permalink Reply
Thank you for taking the time to share this information...much appreciated.
GordonS replied on at Permalink Reply
Just for info.

The "click-on-the-link" wouldn't work for me, but cutting and pasting the link did.
Browser issue, maybe.
fbartsch replied on at Permalink Reply
Great, Thank you. It now worked for me after 1 day for searching!
WebOnTheWebb replied on at Permalink Reply
StevieB replied on at Permalink Reply
I know this solution is four years old now, but the blank login page is happening every time that I am having to change sites over to https, which is almost all my client sites now Google are enforcing it.

This solution, clicking the link in the page source is the only one that works for me to reconnect. Just one thing though, I have found that you do not have to delete the corresponding project, just find the link in the source code and click it, then it reconnects to the original project and I don't have to re-apply all the add-ons!

Thanks for this solution, but I really do wish they would fix whatever the issue is!
nigelcooper66 replied on at Permalink Reply
Thanks StevieB that saved me a lot of hassle and headbanging
mcaconsult replied on at Permalink Reply
Thanks so much for your post. It helped me solve the problem on multiple sites that would not connect to the community.

I was pulling out my hair until I found your post!

Again Thanks.