Allow "Registered Users" to publish page type.

Permalink 1 user found helpful
Hi guys/girls,

Been trying to setup a system the other night where "Registered Users" can post a submission under certain page types.

I've setup the permissions as much as I'd like, though for some reason it only saves the entry as a draft.

Any idea why this is and how I can allow the user to actually publish the posts?

regards,
Joe

View Replies: View Best Answer
enlil replied on at Permalink Reply
enlil
be sure to set permissions to allow the users/groups to approve changes. Here is another recent thread that may be helpful:

http://www.concrete5.org/community/forums/usage/advanced-permissins...
lexbi replied on at Permalink Reply 2 Attachments
I had done that, though now I cannot "edit" a page as a registered user please see attached, and notice that "edit contents" is selected :[
enlil replied on at Permalink Reply
enlil
make sure you apply all the permissions settings on the page type defaults page for the page type you're using as well...
lexbi replied on at Permalink Reply
The previous screenshots were from the page type defaults permissions
enlil replied on at Permalink Reply
enlil
So are the permissions on the page that will get the sub page added different than the page type defaults permissions?? And if so does the new page inherit the permissions of the parent page or the page type defaults??
lexbi replied on at Permalink Reply
Hi enlil,

First off thanks so much for helping me so far, I know users can be annoying (and I'm sure I'm being too).

Basically I'm trying to allow registered users to post a new page under home. This page type is called "main entry".

I have set subpage permissions to the home page as "Inherit page type default permissions".

I believe that when a user posts this page under home, the permissions of this new entry do not have "inherit page type defaults" set. Instead assigned permissions of the new main entry are set to "by area of site (hierarchy)".
enlil replied on at Permalink Best Answer Reply
enlil
I just fully tested this and here are the MINIMUM permissions settings required for a "registered user" to post a sub page and have access to publish it.


In Dashboard > Page Types > your_page_type-Defaults, hover over the edit button and click permissions. Select "Assign Permissions manually". Make sure "registered users" are allowed to View, Edit Contents, and Approve Changes. Also be sure to click on each individual area like "Add to Main" and "Add to header Nav" and set proper permissions for registered user access. Remember, this will be the permissions on each newly created subpage!!


Next, go to the page where your registered users will be adding sub pages. Hover the edit button and click permissions. Assign Permissions "manually". Subpage Permissions should be set to "Inherit page type default permissions". Now, give registered users access to View, and Add Sub-Page.

Go tell all your registered users they can make pages now ;D

If you have any other troubles, feel free to private message me and I'll see if I cant assist you further...
lexbi replied on at Permalink Reply
Ace thanks for you help I've managed it!
jerryscott replied on at Permalink Reply
I am facing similar issue but the solution does not work for me.

I am on version 8.3.2

Is there is anything else we need to do to allow the registered user to publish the posts directly.