Deleted system "Drafts" page and now Composer error

Permalink
I accidentally deleted the system "Drafts" page and now when I go to "Write" in the Composer section, I get the following error.

mysql error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 1' at line 1] in EXECUTE("select max(cDisplayOrder) from Pages where cParentID = LIMIT 1")


I have restored an old database and overwrote all of the core files but I'm still getting the error. I'm not sure what else I can do to either restore the drafts page or fix my error (I can only assume they are related).

Thanks for the help,
Dan

dcaryll
View Replies:
mkly replied on at Permalink Reply
mkly
Hello,
Was the backup from before you deleted the Drafts single page?

Either way I would go to
http://www.example.com/index.php/dashboard/pages/single/

replace example.com with your site

Then type in
/dashboard/composer/drafts
and clicke "Add"

If that does not work, go to the Full Sitemap
and check the box Options -> "Show System Pages"
Click on the Trash and select "Empty Trash"

Then repeat the above step of attempting to Add the Composer Drafts page.

Best Wishes,
Mike
dcaryll replied on at Permalink Reply
dcaryll
Thanks mkly for your response.

The backup was from before I deleted the page, but it didn't seem to help when I restored.

I had also tried previously to add that page (even after emptying the trash) and I'm still getting the same database error.

I tried adding back the composer and the drafts page, and they both show up in the Single Pages page, but still no drafts in the Full Sitemap.

I really appreciate your help,
Dan