I'm having problem with pretty url

Permalink
I have enable pretty url in my site still i didn't get any pretty url. all i got id &&??/// in my url. pls sum one should help me. here is the link to my site.http://crownconsultnacy.com/index.php?cID=77... thanks in advance

View Replies:
tallacman replied on at Permalink Reply
tallacman
Note: Im not a server guy.

Fatcow may not be allowing your mod-rewrites to work. Those are pretty bad urls, though. How do the links resolve if you disable pretty urls? They should look more likehttp://crownconsultnacy.com/index.php/contact-us...

steve
elvisz replied on at Permalink Reply
steve all the site i have design with concret5 non of them hsve pretty url like this onehttp://ukraineadmission.com/index.php?cID=75... pls help me if you can
tallacman replied on at Permalink Reply
tallacman
Elvisz,

Move your site to inmotionhosting. I think that will solve your problem.
jordanlev replied on at Permalink Reply
jordanlev
Try adding this to your config/site.php file:
define('URL_REWRITING_ALL', true);
jordanlev replied on at Permalink Reply
jordanlev
Also, note that when you're logged in to the site and editing pages, it will often use those "ugly" url's, but that is not what a normal visitor to the site will see -- so test it out by logging out and clicking around your site as a guest too.
iLP replied on at Permalink Reply
iLP
Nothing I tried would work on fatcow hosting, until I stumbled upon this is in a buried thread:

"The problem with your rewrites is that apache thinks "index.php/foo/bar" is supposed to be a file, but of course it isn't :)
I'd suggest trying either

RewriteRule ^(.+)$ index.php?/$1


or

RewriteRule ^(.+)$ index.php/$1 [R]


Note the question mark in rule 1 and the new R flag in rule 2."