On login error: "Checking for updates"...

Permalink 2 users found helpful
Hi there,

Does anyone have any experience with the following issue:
when i log in with a NOT superuser account i get a loading popup with the message "checking for updates". I can't get out of this...

The error occurs here with Concrete5 v5.5.0 in safari firefox and chrome.

Thanks in advance.


View Replies:
dungmarketing replied on at Permalink Reply
same problem now in 5.5.1

firebug gives me a "jQuery.fn.dialog is undefined" inhttp://x.x.x.x/xxxxxx/concrete/js/ccm.app.js?v=......
bishampton replied on at Permalink Reply
I'm getting this too and it seems I can't go back to a working install.

Has anyone had any luck with this before I start the massive task of rebuilding the site?

Phallanx replied on at Permalink Reply
I have just been through this. I went from>>5.5.1.

I'm guessing something changed in 5.5.0 since that is a step I missed out (although I wasn't offered it in the auto-upgrade). However. My gut feeling is that it probably wouldn't have made a difference.

I'm in no way advocating anyone should do what I'm about to tell you. I'm just recounting my experience and I'm quite confident doing this sort of stuff.

Anyhoo. Same error as you. Well, two errors in the ccm.app.js and I also had two files not found, "quicksilver.js" and ccm.layout.js. Put the two files in from the previous install in and ended up with just the two errors.

So there I was. No edit bar (yes the loader:helper(footer.php) was in there) and up pops the "checking" and then I'm left with the modal overlay so cannot do didly squat. So trying to be trixie, I type in a known dashboard url. Whoops, 500 server error. Spent the next 2 hrs trying to figure our whats going on (it was fine on the Xamp install). I don't really get very far, because I cannot go into the dashboard and change stuff.

That's the point I gave up on 5.5 and decided to go back to and let my users get back to the goodies. I took out the upgrade define in the site.php and now my website looks a bit odd, but seems to be working-obviously need to clear the cache!. Log in to the dashboard. Hmmm, now there is no site-wide settings (where the "clear cache" would be) and I have other buttons like Dashboard, Dashboard Display et al.

So really peeved by now and decide enough is enough. I fired up phpMyAdmin and imported the DB backup that I'd saved. Then I fired up Filezilla and deleted everything in the cache directory. That done, still have no site-wide settings and these useless buttons that take me to blank pages where useful buttons used to be (bugger).

Since I had also done an entire site backup from within Cpanel I was happy to delete all the tables in the database, use phpMyAdmin to restore the db from the cpanel backup and smartly followed that by the backup from concrete5 (they were different) and finally (4 hrs later) I'm back to Two mins to upgrade. 4 hrs to downgrade.

I really should listen to my own advice. "If it aint broke, don't fix it".
larsnieuwenhuizen replied on at Permalink Reply
The problem is in the new startup screen in v5.5 which you get when you login. The strange thing is that the issue i had was that only users apart from the super users experienced this. I didn't matter which user as long as it wasn't the super user.

Now i created another user (i already tried with 3 others) and all of the sudden the problem was gone for all the users...

So the problem is gone here but it still bothers me i don't know what caused the issue...

When anybody finds out please let me know!
Phallanx replied on at Permalink Reply
Indeed. It's probably just an ordering dependency on the ccm.app.js and just getting things in the right order would get rid of the errors. Unfortunately, it is now as crucial to the core as jquery is to jquery plugins and without it, nothing works properly.
Phallanx replied on at Permalink Reply
Right. Got to the bottom of it.

dashboard.php was the issue. If anyone has done the javascript (jquery) mod to add jquery to the main interface, then it is likely you have an override "dashboard.php" in the top level "themes/core" directory. Removal of this solved the missing files (they are not needed for 5.5.x) and the spinner behaved as expected. I had other errors that needed to be resolved (not relating to this thread), but this was the main one.

Happy bunny now :)
bishampton replied on at Permalink Reply
Nice one Phallanx!

I managed to find a sql backup from a few months back.
So, did the long winded method of re-building the database tables and going back to 5421. Then did the 5422, 550, 551 upgrades in order.

Now it works fine!

I also have plenty of sql backups too!

Cheers for the help guys!
bishampton replied on at Permalink Reply
I don't quite believe this.
After fixing the spinny checking for updates nonsense last night. I did loads of work on my site. Nothing major, just shifting blocks around and adding content.

I've gone to log on just a few moments ago and guess what's back?

Stupid spinny thing!!!!!!!!!!

HELP Please!!!!!!
TorstenKelsch replied on at Permalink Reply
Happens to me, too, on an upgraded installation from 4.2.2 to 5.5.1, but in my case when I log in as Superuser. When logged in as a normal user, I don’t get bothered by the spinning thing. Strange!

On a fresh install the spinning update wheel appears also, but it disappears again after showing some information, or in other words: it behaves normally. So, I guess it has something to do with old entries in an existing database.
TorstenKelsch replied on at Permalink Reply
I found out what was wrong: In the database, there was a missing field in table Config. Just insert something like
INSERT INTO Config (cfKey,timestamp,cfValue,uID,pkgID) 
VALUES ('NEWSFLOW_LAST_VIEWED','2012-01-27 00:47:23','1327621643',1,0)

and the same for the users with ID 2 etc. I only hope this helps permanently.
bishampton replied on at Permalink Reply
You are my new personal hero!

Fixed. I'm guessing from the information in the config and user tables that this issue will probably resurface all too frequently.

But at least this gives me a quick fix.

Thanks again!
TorstenKelsch replied on at Permalink Reply
Glad I could help!
s4pphir3 replied on at Permalink Reply
I had the same problem and your solution worked like a charm (eventhough I already had the field in database but modyfing it did the job).
Thank you :)
TorstenKelsch replied on at Permalink Reply
It re-appeared a day later. Now I have set the timevalue and UNIX time stamp to a date in the future:

2037-01-01 00:00:00

We’ll see if it works all right permanently or if it will cause new errors.
larsnieuwenhuizen replied on at Permalink Reply
Works here as well. Thanks! =D
iLP replied on at Permalink Reply
Did not resolve the issue for any users on my manual upgrade from 5.4.2 to 5.5.1. Considering downgrading.

Any official word on this bug?
spencerhudson replied on at Permalink Reply
I've tried the MySQL update and it didn't work. my superUser is uneffected,only my other users see the message. Seems like a bug that needs to be stamped on asap.

FYI: There are a few questions like this, listing here to save some finding.




It points to the answer in, but yet to get it to work:
spencerhudson replied on at Permalink Reply
I've applied these and the "checking for updates" has stopped:


interesting to see if this works for others.
juliankauai replied on at Permalink Reply
that worked for me. allowed to disable the maintenance mode and get the site back online.

i would like to know if this is the official fix.

lehr replied on at Permalink Reply
For now we give every user except the superuser an update to the NEWSFLOW_LAST_VIEWED config entry in the header element of the theme.

Works fine and the super user can get updates like before.
    $u = new User();
    if($u->uID > 1)
        $u->saveConfig('NEWSFLOW_LAST_VIEWED', time() + (24 * 60 * 60));
spencerhudson replied on at Permalink Reply
lehr, great bit of code ... well done
andrew replied on at Permalink Reply
Any chance you can private message me some access to your site? I'd like to get this stamped out as well. It's definitely not supposed to behave the way you're describing.
iLP replied on at Permalink Reply
I tried all of the above solutions without success. For whatever it's worth, I reverted to 5.4.2, and then did the update via SImpleScripts, and everything works perfectly now. Something host specific configured via the hosted SimpleScripts that was not available in dashboard or manual updates?
andrew replied on at Permalink Reply
I found a site affected by this and if I disabled the redirect caused by Wordpress for concrete5 add-on it fixed it. I am PMing the developer – just a heads up to anyone else reading this who has that add-on installed.
swattlebucket replied on at Permalink Reply
Does anyone know if this issue has been resolved in the core? I still have users getting this error message and I can't figure out how to fix it. If it's been addressed at the core level does anyone know when an update might be made available? Any assistance or info on this item is appreciated. Thank you.
johnson72223 replied on at Permalink Reply
I am currently getting this same error and have nothing to do with Wordpress on my site.

This is crazy... LOL

Can someone post a step-by-step resolution?