Page forbidden after edit defaults

Permalink 1 user found helpful
Hi,

When I try to get to Pages & Themes > Page Types > Output button > Edit Defaults button it throws me to the page forbidden page. It happens with the Admin user and with users from the Administrators group.

I've been searching on the forum and trying some permission changes, with no success. I haven't activated advanced permissions.

I'm using Concrete5 8.1.0 version. Could anyone help me with this issue?

Thanks!

Juan Ramon

jrsanche
View Replies:
Doki replied on at Permalink Reply
Doki
Could it be that you don't have proper access on the files in your theme?

Check the ownership and permissions of the files you're accessing when setting defaults.

As well, are you running SELinux? If so, this may not be set properly.

All guesses of course, but worth checking.
Doki replied on at Permalink Reply
Doki
Could it be that you don't have proper access on the files in your theme?

Check the ownership and permissions of the files you're accessing when setting defaults.

As well, are you running SELinux? If so, this may not be set properly.

All guesses of course, but worth checking.
jrsanche replied on at Permalink Reply
jrsanche
Hi Doki,

I've checked the permissions and they grant read, write and execution, so I guess they are right.

We are using CentOS 7 Linux.

Thanks for your answer!
Doki replied on at Permalink Reply
Doki
Try running the following command from the command line:

sestatus


If you see

SELinux status:                 enabled


it may be a SELinux issue.
jrsanche replied on at Permalink Reply
jrsanche
Thanks for clarifying that SELinux is not a Linux distribution... :-O X-D

I've tried the command line and it is disabled, so it doesn't seem a SELinux problem.

Thanks for your answer! :-)
Gondwana replied on at Permalink Reply
Gondwana
I've had weird things happen with mod_security. If nothing else helps, you could ask your host to see if anything is unnecessarily triggering a mod_security rule, and have that rule relaxed.
jrsanche replied on at Permalink Reply
jrsanche
Hi Gondwana,

We are not using mod_security. We are using nginx as our web server together with Concrete5. Do you know if there is anything similar to mod_security in nginx that could cause the problem?

Thanks for your answer!