Problem Choosing Image after Upload

Permalink
If I upload an image using the "Asset Library" file selector. The image uploads correctly I enter any extra property bits and assign to any sets. I close or click update, and then am taken back to my filemanager.

This is a blanket problem across my site affecting all blocks, that I can not work out alone?

The problem site is running 5.4.1.1 so I am not to sure whats going on?

From here I can not add any image, choosing an image, via left click>choose or via the checkbox does not matter. The Filemanager then closes and the image is "not" inserted.


If I do not upload an image then I can go into the file manager and everything works as normal

I have assumed that maybe it was something to do with the ccm.filemanager.js but can see nothing different when I compare the version with a site that works.

My header loads in these scripts which I think is default to a concrete site.

<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.ui.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/jquery.rating.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.dialog.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.menus.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.forms.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.search.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.filemanager.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/ccm.colorpicker.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<link rel="stylesheet" type="text/css" href="/concrete/css/jquery.ui.css?v=ac0365a41859e81088a811ce35fa96da" /> 
<script type="text/javascript" src="/index.php/tools/required/i18n_js"></script> 
<script type="text/javascript" src="/concrete/js/jquery.form.js?v=ac0365a41859e81088a811ce35fa96da"></script> 
<script type="text/javascript" src="/concrete/js/jquery.metadata.js?v=ac0365a41859e81088a811ce35fa96da"></script> 
<script type="text/javascript" src="/concrete/js/jquery.ui.js?v=ac0365a41859e81088a811ce35fa96da"></script> 
<script type="text/javascript" src="/concrete/js/quicksilver.js?v=ac0365a41859e81088a811ce35fa96da"></script> 
<script type="text/javascript" src="/concrete/js/jquery.liveupdate.js?v=ac0365a41859e81088a811ce35fa96da"></script>


I have also used the designer content and a couple of sliders on each page, I have removed the scripts that these blocks call to try and stop any conflicting js calls. Nothing I can do seems to work?

has anyone experienced anything like this before?? or can maybe point me in a better direction to look at.

I Can see the client being annoyed at having to upload an image first and then, reselect the add image to choose it.

This also affects every block on my site that uses the image selector including the content block I was about to submit it as a bug when I discovered that it works on my latest site

I am using google chrome to develop on but as I said this works on some sites I have but not others?

Inspecting in Firebug, I get the following
[{"error":false,"filePathDirect":"\/files\/3613\/0209\/1590\/_r2_c2.jpg","filePathInline":"\/index.php\/download_file\/view_inline\/472\/","filePath":"\/index.php\/download_file\/view\/472\/","title":"_r2_c2.jpg","fileName":"_r2_c2.jpg","thumbnailLevel1":"\/files\/thumbnails\/3613\/0209\/1590\/_r2_c2.jpg","thumbnailLevel2":"\/files\/thumbnails\/level2\/3613\/0209\/1590\/_r2_c2.jpg","thumbnailLevel3":null,"fID":"472","width":673,"height":369}]
So I can not see anything wrong going on here? But it then gets stuck Transferring Data in Firefox (Chrome just silently fails)

Ok so looking through this I can see that the ccm_chooseAsset is being passed through as a function when I upload an image
then the file manager seems to have trouble running the getJSON function.

I think I am back to thinking this may be an old bug that the update has not fixed, but latest release seems to have solved.

Any help would be gratefully received.

Many Thanks
Sean

TheRealSean
View Replies: View Best Answer
TheRealSean replied on at Permalink Reply
TheRealSean
I think I have worked out that it is something in my DB causing this??

as If I run a fresh install it works fine but if I copy the old DB over then it breaks again.

Does anyone have any idea on how I can debug this?? and work out whats causing this problem without having to re-enter a table at a time?
TheRealSean replied on at Permalink Best Answer Reply
TheRealSean
It would appear to be a problem with the file attributes that causes this.

I have added a text area as an attribute with "Rich Text - Basic Controls"

Removing the "Rich Text" and making it plain text solves the issue.

Seems like a bug as I assume the use addition of the rich text when loading the sets window triggers the ccm_chooseAsset to be something other then false?

I would have preferred to have had "rich text" linked with a photo,

Now I have to create a block and then link the rich text with that and then link the fID to that block there is probably a better way to do this so of anyone can again point me to a better solution I am all ears thanks

Sean