Revising form email sender

Permalink
Hi All,

I have a client that requested that when the form is sent, it lands in her mailbox. If she tries to reply to it, it replies to herself. Is there a way to edit the code to reply to the form senders email address?

I have read the other forums and have it so that it sends from her email address now but when reply is clicked, now the to: cell is empty.

Any suggestions, instructions, etc. would be greatly appreciated. I have tried to explain to her that the form is being sent from within the site not from the people filling out her form so when replying, she is replying to herself.

Thanks

surfsupjoe125
View Replies:
triplei replied on at Permalink Reply
triplei
Are you using the 'email address' field type for the email field in the form? If so, there is a checkbox to 'reply to this address'.

This sets the reply-to header for the email notification that is sent out. It probably will still show as coming 'from' the form block email address (which defaults to the site admin) but that can be changed by adding something like the following to application/config/concrete.php

return array(
    'email' => array(
        'form_block' => array(
            'address' => '[email protected]',
            'name' => 'Form Submission On My Site'
        )
    )
);


Hopefully that helps get you going in the right direction
surfsupjoe125 replied on at Permalink Reply
surfsupjoe125
Hi Triplei,

Thanks for reaching out. I do know about this feature within the 5.7 form.
For some reason it did not show up. I finally looked at the HTML for that
page which did have the "reply to this email" so it was there. I then kept
working on it until I finally got that portion to show up and solved the
problem. Not sure why it was so wonky but got it. I appreciate your
response and suggestions.

Cheers,


*Joe Notarianni*
Tel:(239) 434-7095
Cell:(239) 298-3984