SVG Images

Permalink
I have uploaded an svg image to the file manager, now I want to add an image block but it cant see the svg file?

C5.8.0.1

View Replies: View Best Answer
mesuva replied on at Permalink Reply
mesuva
I built this for 5.7, but I'm pretty sure we've used it just recently in v8

https://github.com/Mesuva/svg_image...
Download the zip, unzip it to the packages folder (remove the -master from the folder name) and install.

I'd suggest updating to 8.1 too,
Responsive replied on at Permalink Reply
Responsive
Hi , unfortunately this does not seem to work for me in 8.1 as I am unable to select svg in both Image block and your SVG Image block.
JohntheFish replied on at Permalink Reply
JohntheFish
There are a bunch of issues with svg in 8.1. See
https://github.com/concrete5/concrete5/issues?utf8=%E2%9C%93&q=s...
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi Responsive,

The upcoming 8.2 version of concrete5 will address these SVG issues.
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Has this been fixed? I can upload an SVG, add it to an image block and see it, but it doesn't appear on my page. Using the Fundamental theme within the topbar_logo stack. JPG and PNG images work fine.
MrKDilkington replied on at Permalink Reply
MrKDilkington
@TeKnoZiz

What version of concrete5 are you using?
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Hi, version 8.4.3. You can see it herehttp://dev.teknoziz.com/hansendx2...
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
Just saw that the logo shows up on my phone, but not on my tablet or desktop, weird.
ConcreteOwl replied on at Permalink Best Answer Reply
ConcreteOwl
In your main.css file you have this
@media only screen and (min-width: 40.0625em)
.ccm-page .top-bar .logo img {
    max-height: 80px;
    width: auto;

Change it to this
@media only screen and (min-width: 40.0625em)
.ccm-page .top-bar .logo img {
    max-height: 80px;
    width: auto;
    height: 80px;
TeKnoZiz replied on at Permalink Reply
TeKnoZiz
So what was going on that this minor change fixed the display (thanks very much!)? Was it because the height wasn't being set it was displaying very large and it was showing the white at the top?
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Yes the height was missing from your css and so the browser was setting it at 0 pixels..
I am glad it fixed it for you..