Developing (v7+)

concrete5 8.4.0 is Now Available

I am very happy to announce that concrete5 8.4.0 is now available. It's a huge release. You can check out everything that's new here: https://documentation.concrete5.org/developers/background/version-history/840-release-notes Please download it and …

API documenation for 5.7.5.13 missing

I visited https://documentation.concrete5.org/api/8.3.2/ The pull down button does not have 5.7.5.13. Manually entering the URL https://documentation.concrete5.org/api/5.7.5.13/ does not work and redirected to 404.

How to add custom user attribute programmatically from package

Updated: problem solved with this code. Adding "Membership Type" custom user attribute and populate this with 2 options (Publisher and Reader). Also, this attr is set as required on register. [code] public static function installUserMembershipTypeKey…

Reorder Registration Page Attributes

I believe this was possible in V5x but I can't see how to do it in V8.3.2 ... Have added new attributes to the members to show on registration page but I need to alter their display order. Don't seem able to simply drag the attributes in the list to re…

Weird user avatar bahaviour (v8.3.1)

Hi My pagetype has a User built in attribute in its composer form so I can choose an author for the page. I am getting the user and it is correctly showing the first name and last name for that user: [code] $uID = $c->getCollectionUserID(); if($uID…

accordion menu not working on iPhone

Hi, I am using accordion drop-down for a menu list. It is working fine on Android devices. But it's not working on iPhone devices. I tried in mobile view response, it is working on the site. But when I tried the same on the device, it is not working.…

Porting WP plugins/apps

I am working with a client who currently uses Wordpress/Graffiti along with the Thrive Leads subsystem. After about a month trying to fix what was broken and what they wanted I threw in the towel. I had not worked with Wordpress for some time, but it's …

Primary nav contains IP instead of domain

Not sure where to put this, but a client of ours has an odd thing where the primary navigation (autonav) is displaying the IP address for the server in the link, rather than the domain. Client reports this happening in IE and Chrome. I logged in to the…

Filter Posts