Developing (v7+)

how to make calls to the database? First time with concrete5

Hi, it's the very first time I'm using Concrete5 and I have some questions! I had a small database with 6 tables, which I don't know where to put now (in the database with the tables of Concrete5? Or I have to create a new database?), and I want to make …

Safely Update from 8.2.1 to latest version?

I searched but couldn't find a direst answer. I have a site that needs updating. It's at 8.2.1 Looks like a manual update is required. Should I update to the latest version or take an interim step(s)? The site uses Express quite heavily and I'd hate…

Unable to save task or user permissions

Hello! I am trying add a group to a custom task permission that I created and for some reason adding the group doesn't "stick". Meaning, I grant access to the group, the interface under "Task Permissions" shows that group next to my custom permission, …

cPanel Webmail Integration

I saw a few notes from MANY years ago. Has anyone developed a way to integrate webmail into the user system? IE: Can I have someone login to a site and click a button to access their webmail without having to log in separately? Perhaps a cPanel auth…

Blogging, Email Newsletters and Facebook Questions (continued)

I saw this post about Blogging, Email Newsletters and Facebook Questions on here from 2013 but could use some assistance. Wondering what has changed since 2013. We are a non-profit that is trying to simplify communication to seniors. We are looking at …

Changing Database Character Set Results in Error

Hi, I'm trying to change a site's character set to utf8mb4 but I get an error. Call to a member function add() on null. The site is running Concrete5-8.5.4 and is running mariaDB which its version is 5.5.68. I don't have any problems change the c…

Error: Call to a member function getLocale() on null (1)

Hello, i have footer.php this simple code: $Locale = \Concrete\Core\Multilingual\Page\Section\Section::getCurrentSection(); echo $Locale->getLocale(); The language is displayed correctly, but there is an error in the log: Exception Occurred: /ele…

Filter Posts