5.7.5.13 -> 5.8.1

Permalink
For some reason the dashboard upgrade page shows no new updates/versions to go to even though I'm only on 5.7.5.13 and I thought 5.8.1 is the newest version? I even hit the check for updates button and get nothing. I can do it manually, but it would be nice to resolve why it isn't showing there? Any help?

Thanks, appreciate any help with this.

EDIT: Anyone?

MrWizard
View Replies:
MrWizard replied on at Permalink Reply
MrWizard
Does anyone have any advice? I would really like to let C5 do the upgrade rather than manually doing it if possible.
Gondwana replied on at Permalink Reply
Gondwana
I suspect the developers are delaying automatic updates to version 8 until some more bugs are squashed. This is A Good Thing.
frz replied on at Permalink Reply
frz
Nothing specific, no. If there's a bug you think is a blocker, I hope you've reported it so we can resolve it.

There are a few add-ons that need a line or two of code changed before they work on v8, and while the installer DOES trip errors letting you know that you have stuff installed that might not work, it's nice to have some overlap time to let people catch up.
weyboat replied on at Permalink Reply
weyboat
I have tried many times to update a site from 5.7.5.13 to 5.8.1 and the process always ends with this error.
PHP Fatal error:  Maximum execution time of 300 seconds exceeded in H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php on line 91

I have tried using PHP 5.6 and PHP 7.
I have tried on my local wamp server and a live server.
My last attempt (last night) failed and here is the stack trace
22:30:36 UTC] PHP Fatal error:  Maximum execution time of 300 seconds exceeded in H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php on line 91
[16-Feb-2017 22:30:36 UTC] PHP Stack trace:
[16-Feb-2017 22:30:36 UTC] PHP   1. {main}() H:\wamp64\www\concrete5.7\index.php:0
[16-Feb-2017 22:30:36 UTC] PHP   2. require() H:\wamp64\www\concrete5.7\index.php:3
[16-Feb-2017 22:30:36 UTC] PHP   3. require() H:\wamp64\www\concrete5.7\concrete\dispatcher.php:18
[16-Feb-2017 22:30:36 UTC] PHP   4. require() H:\wamp64\www\concrete5.7\concrete\bootstrap\configure.php:52
[16-Feb-2017 22:30:36 UTC] PHP   5. Concrete\Core\Foundation\Runtime\DefaultRuntime->run() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\dispatcher.php:39
[16-Feb-2017 22:30:36 UTC] PHP   6. Concrete\Core\Foundation\Runtime\Run\DefaultRunner->run() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Foundation\Runtime\DefaultRuntime.php:102
[16-Feb-2017 22:30:36 UTC] PHP   7. Concrete\Core\Application\Application->handleAutomaticUpdates() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Foundation\Runtime\Run\DefaultRunner.php:63
[16-Feb-2017 22:30:36 UTC] PHP   8. Concrete\Core\Updater\Update::updateToCurrentVersion() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Application\Application.php:258
[16-Feb-2017 22:30:36 UTC] PHP   9. Doctrine\DBAL\Migrations\Version->execute() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Updater\Update.php:196
[16-Feb-2017 22:30:36 UTC] PHP  10. Concrete\Core\Updater\Migrations\Migrations\Version20160725000000->up() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\vendor\doctrine\migrations\lib\Doctrine\DBAL\Migrations\Version.php:290
[16-Feb-2017 22:30:36 UTC] PHP  11. Concrete\Core\Updater\Migrations\Migrations\Version20160725000000->importAttributeKeys() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Updater\Migrations\Migrations\Version20160725000000.php:1196
[16-Feb-2017 22:30:36 UTC] PHP  12. Concrete\Core\Updater\Migrations\Migrations\Version20160725000000->addAttributeValue() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Updater\Migrations\Migrations\Version20160725000000.php:315
[16-Feb-2017 22:30:36 UTC] PHP  13. Doctrine\DBAL\Connection->insert() H:\wamp64\www\concrete5.7\updates\concrete5-8.1.0\concrete\src\Updater\Migrations\Migrations\Version20160725000000.php:408

In an experiment, I did manage to successfully do an update but this was from a freshly installed copy of 5.7.5.13 with no content and upgrading immediately to 5.8.1, however, the upgrade must have been very close to the timeout limit when it eventually completed..
MrWizard replied on at Permalink Reply
MrWizard
So currently from the upgrade admin page I cannot go to any version of 5.8? Just wanted to make sure I understood correctly.