Adding new user - Undefined index: uDefaultLanguage

Permalink
I have a v8.5.1 site and am trying to add a new user but get the following error:

public/concrete/controllers/single_page/dashboard/users/add.php

Whoops \ Exception \ ErrorException (E_NOTICE)
Undefined index: uDefaultLanguage
$controller, $this->request, $uak->isAttributeKeyRequiredOnRegister()
   );
   if (!$response->isValid()) {
      $error = $response->getErrorObject();
      $this->error->add($error);
   }
}
if (!$this->error->has()) {
   // do the registration
   $data = ['uName' => $username, 'uPassword' => $password, 'uEmail' => $_POST['uEmail'], 'uDefaultLanguage' => $_POST['uDefaultLanguage']];
   $uo = UserInfo::add($data);
   if (is_object($uo)) {
      if ($assignment->allowEditAvatar()) {


Looking at the POST data, sure enough uDefaultLanguage isn't set. Should it be? Also, note that an empty uDefaultLanguage index exists in the session, but I do not think this is relevent.

GET Data empty
POST Data
uName   john
uPassword   secret
uEmail   john@c5.com
akID   Array ( [14] => Array ( [value] => 1 ) [15] => Array ( [value] => 1 ) )
gID   Array ( [0] => 3 )
ccm_token   1566491309:0a15b8f3fd470f28f8de5d0497b57c0a
add   Add
Files empty
Cookies
CONCRETE5   qo1jhm6emetimrold3td40m5o6
CONCRETE5_LOGIN   1
ConcreteSitemapTreeID   1
includeSystemPages   1


Looking at the add user form, there is no input with uDefaultLanguage as the name which might be the cause.

/dashboard/system/basics/multilingual is set up for only english:
Languages
You don't have any interface languages installed. You must run concrete5 in English.
You can configure the site languages in the Multilingual Setup dashboard page.

Don't know if relevant, but installed the site using composer withhttps://github.com/concrete5/composer... .

Any thoughts? Thank you

PS. Should I be posting these type of questions under Installation Help or something else?

View Replies: View Best Answer
ConcreteOwl replied on at Permalink Best Answer Reply
ConcreteOwl
Possibly you don't have a default language set up.
Go to System & Settings > Languages and ensure you have the default language set in there.
NotionCommotion replied on at Permalink Reply
You are right! But how do I add one? As seen athttps://i.ibb.co/fDYh05S/c5-lang.png,... all that this page shows is:

Languages
You don't have any interface languages installed. You must run concrete5 in English.
You can configure the site languages in the Multilingual Setup dashboard page.
NotionCommotion replied on at Permalink Reply
I don't know why this worked but it did. I just went to /dashboard/system/multilingual/setup and added UK English as a language and all is good. Any thoughts why this was necessary? Oh well, all's well that ends well.