Blocks disappear when page is edited after C5 upgrade

I am trying to upgrade my website from C5 v5.3.3.1 to a more recent release. The upgrade itself runs smoothly with no problems (tried and the older But when I go and edit one of the pages after the upgrade all content gets deleted. Versioning still works, so I can always go back. But I am stuck with no ability to make updates to my sites w/o recreating it entirely.
I've tried disabling caching with no luck.

Any ideas?

View Replies: View Best Answer
12345j replied on at Permalink Reply
try restoring the database/ downgrading
mhessler replied on at Permalink Reply
I did. I am back on v5.3.3.1. Everything looks fine and I can make edits to my pages.
But I want to upgrade to a newer version eventually.
Anyone else having the same problem?
12345j replied on at Permalink Reply
mhessler replied on at Permalink Reply
Did that too. Like I wrote, I have no problem upgrading the site including the DB, but can't make any edits to blocks afterwards w/o losing all the existing content on a page.
12345j replied on at Permalink Reply
just seems like a faulty upgrade. maybe a clean install? or try taking the concrete5.4.0.5/concrete5/blocks folder and uploading that in the update folder.
mhessler replied on at Permalink Best Answer Reply
I had to do a fresh C5 install and migrate the DB data into the new structure.
I also removed all add-ons that I am currently not using.
Finally got it working.
oaknshield replied on at Permalink Reply
hi - im having same issue
upgrade from -> everything look good but the minute i add something -- everything disappears...

what do you mean migrate the database into the new structure??? u mean add over everything ...

thanks for nay info
mhessler replied on at Permalink Reply
Not sure how familiar you are with database administration. But a DB basically consist of a structure (of tables) and the data that's in it. Concrete upgrades come with updates to the structure. So you need to export your data using an admin console, build a blank version of the new DB, and re-import your data into the new DB.
That's what I did. Make sure that you make backups every step of the way, otherwise you might overwrite something.
I hope this helps.
dstrickler replied on at Permalink Reply
I just upgraded to v5.6.0.2 and have the same blank window when I try and add int a block. It should pop up with all the kinds of blocks available, but instead is just blank.

Any clues on this? Sounds like it happened in previous versions as well.