Cannot import database to host after 5.7.13 to 8.5.1

Hello - I'm hoping that someone can help with this. I've got several sites that have been updated in Mamp from 5.7.13 to 8.5.1. This wasn't a smooth process, however, I've hit a roadblock trying to upload the database from MAMP to the live web host - I keep getting this error.

Has anyone seen this, and can offer any help? I'm stuck here.

SQL query:
-- Indexes for table `AreaLayoutPresets`
ALTER TABLE `AreaLayoutPresets`
  ADD PRIMARY KEY (`arLayoutPresetID`),
  ADD KEY `arLayoutID` (`arLayoutID`),
  ADD KEY `arLayoutPresetName` (`arLayoutPresetName`)
MySQL said: Documentation
#1709 - Index column size too large. The maximum column size is 767 bytes.
[ Back ]

View Replies:
Gondwana replied on at Permalink Reply
Unfortunately, the default database character encoding (collation) was changed in 8.5. It's now some variant of utf8mb4. This means that some data can require more space to store, although the allowable lengths are no greater.

I think there are some command-line (and maybe phpMyAdmin) solutions in the forum for forcing the collation to something else.

I had insurmountable trouble with the latest version of xampp, which still doesn't fully support the new c5 encoding. I think c5 8.5 can still work with the earlier encoding.
juddc replied on at Permalink Reply
I've seen mention of this, and have tried a few things from various sources (manual search & replace, phpMyAdmin collation change), but I still get nothing.

I've see this ( but it doesn't seem to do anything for me.

I'm hoping someone has a fix.
kspitzley replied on at Permalink Reply
I'm having this issue trying to import a utf_unicode database from Windows XAMPP to Bluehost. It erros on the arHandle key in the AreaPermissionAssignments. I can't seem to figure this out and obviously on shared hosts, which a lot of people use, you only have so many options to configure mysql and php.