Default email

Permalink
Hi-
I am on webhostinghub and installed Concrete5.8.3 using the Softaculous utility via cpanel. When I go to "systems and settings" to test my email it keeps defaulting the email address to [email protected] . Based on the documentation I then changed the concrete.php file in /concrete/config so that default, form_block and forgot_password emails are set to the proper address -- [email protected] I shut down the server and then restarted. The email under system and settings is still set to [email protected] .
Is there someplace else to reset this address. I have looked everywhere and can't find the address. Maybe this is in a database table?
Thank you.

View Replies:
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi dgreer,

Changes made to files in the concrete\ directory will be overwritten when concrete5 is updated. Adding the changes to the application\ directory will prevent them from being overwritten.

In the next version of concrete5, there is a dashboard page for making these email changes instead of a config file.

Example:
application\config\concrete.php
<?php
return [
    'email' => [
        'default' => [
            'name' => '',
            'address' => '[email protected]',
        ],
        'forgot_password' => [
            'name' => '',
            'address' => '',
        ],
        'form_block' => [
            'address' => '',
        ],
        'register_notification' => [
dgreer replied on at Permalink Reply
I am having this problem on a new install in a new account. Based on my testing I now think the email test under "systems and settings" is pulling the email account from the user table for the admin account.

Glad to hear there will be an easier way to update this information in the future.
echan101 replied on at Permalink Reply
I just installed 8.3.2 on TMDHosting using Softaculous, and I can't send emails, not even test emails. The test email says "success" when using PHP mail and also "success" when using SSL SMTP, so it thinks it's sending out the mail.

Strangely Concrete5 is saying the following: You will receive a test message from [email protected]

I have no idea where it is getting that email address from!!
echan101 replied on at Permalink Reply
Well the above PHP file seems to explain why, it looks like that strange email address is the default. I don't know why that is the default now. It really should have the domain name.
I definitely had to add that PHP file and add an email address under the same domain name. Otherwise PHP mail and SSL SMTP will silently bounce the email because it is considered spam or mail server abuse.