IIS PHP can not upload more than 2mb files

Permalink
Hi,

I am trying to upload images or files that are large 2mb with no luck. If it just under it will and I have change Max Upload to 25M in the php.in file and IIS limit which is defaulted at 4mb.

Any assistance would be appreciated.


# concrete5 Version
Core Version - 8.5.2
Version Installed - 8.5.2
Database Version - 20190925072210

# Database Information
Version: 5.1.70-community
SQL Mode: STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

# concrete5 Packages
None

# concrete5 Overrides
None

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Microsoft-IIS/7.5

# Server API
cgi-fcgi

# PHP Version
7.1.19

# PHP Extensions
bcmath, calendar, cgi-fcgi, Core, ctype, curl, date, dom, exif, fileinfo, filter, gd, gettext, hash, iconv, imap, intl, json, libxml, mbstring, mcrypt, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, pdo_sqlsrv, Phar, readline, Reflection, session, SimpleXML, soap, SPL, sqlsrv, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, Zend OPcache, zip, zlib

# PHP Settings
max_execution_time - 300
log_errors_max_len - 1024
max_file_uploads - 200M
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 8M
sql.safe_mode - Off
upload_max_filesize - 200M
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pdo_sqlsrv.client_buffer_max_kb_size - 10240
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 10000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

View Replies:
jero replied on at Permalink Reply
jero
Your max_file_uploads looks weird. It should be a number, e.g. 20, not a memory value. The standard value is 20 - it's the number of concurrent files that can be uploaded and nothing to do with size..

I would also look at increasing your memory_limit. At least 256MB, preferably 512

Also post_max_size should be at least as large as your upload_max_filesize