Install Error

Permalink 1 user found helpful
I am doing a new install and got this.
The previous page said all requirements were met.
Now what should I do?

Install concrete5
Version 5.7.5.7
Declaration of Carbon\Carbon::setTime($hour, $minute, $second = 0) should be compatible with DateTime::setTime($hour, $minute, $second = NULL, $microseconds = NULL).
Trace:
#0 [internal function]: Whoops\Run->handleError(2, 'Declaration of ...', 'E:\\inetpub\\Doma...', 2138, Array) #1 E:\inetpub\Domains\guerrilla-rf\concrete\src\Error\Run\PHP7CompatibleRun.php(36): call_user_func_array(Array, Array) #2 E:\inetpub\Domains\guerrilla-rf\concrete\vendor\composer\ClassLoader.php(412): Concrete\Core\Error\Run\PHP7CompatibleRun->__call('handleError', Array) #3 E:\inetpub\Domains\guerrilla-rf\concrete\vendor\composer\ClassLoader.php(412): include() #4 E:\inetpub\Domains\guerrilla-rf\concrete\vendor\composer\ClassLoader.php(301): Composer\Autoload\includeFile('E:\\inetpub\\Doma...') #5 [internal function]: Composer\Autoload\ClassLoader->loadClass('Carbon\\Carbon') #6 E:\inetpub\Domains\guerrilla-rf\concrete\src\File\File.php(463): spl_autoload_call('Carbon\\Carbon') #7 E:\inetpub\Domains\guerrilla-rf\concrete\src\File\Importer.php(174): Concrete\Core\File\File::add('avatar_none.png', '191515009747', Array, Object(Concrete\Core\File\StorageLocation\StorageLocation)) #8 E:\inetpub\Domains\guerrilla-rf\concrete\src\Backup\ContentImporter.php(1030): Concrete\Core\File\Importer->import('E:\\inetpub\\Doma...', 'avatar_none.png') #9 E:\inetpub\Domains\guerrilla-rf\concrete\src\Package\StartingPointPackage.php(255): Concrete\Core\Backup\ContentImporter->importFiles('E:\\inetpub\\Doma...', false) #10 [internal function]: Concrete\Core\Package\StartingPointPackage->import_files() #11 E:\inetpub\Domains\guerrilla-rf\concrete\controllers\install.php(294): call_user_func(Array) #12 [internal function]: Concrete\Controller\Install->run_routine('elemental_full', 'import_files') #13 E:\inetpub\Domains\guerrilla-rf\concrete\src\Controller\AbstractController.php(161): call_user_func_array(Array, Array) #14 E:\inetpub\Domains\guerrilla-rf\concrete\src\Routing\ControllerRouteCallback.php(27): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #15 E:\inetpub\Domains\guerrilla-rf\concrete\src\Routing\Router.php(142): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #16 E:\inetpub\Domains\guerrilla-rf\concrete\src\Support\Facade\Facade.php(119): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #17 E:\inetpub\Domains\guerrilla-rf\concrete\src\Application\Application.php(445): Concrete\Core\Support\Facade\Facade::__callStatic('execute', Array) #18 E:\inetpub\Domains\guerrilla-rf\concrete\bootstrap\start.php(230): Concrete\Core\Application\Application->dispatch(Object(Concrete\Core\Http\Request)) #19 E:\inetpub\Domains\guerrilla-rf\concrete\dispatcher.php(36): require('E:\\inetpub\\Doma...') #20 E:\inetpub\Domains\guerrilla-rf\index.php(2): require('E:\\inetpub\\Doma...') #21 {main}

gwardell
View Replies: View Best Answer
jero replied on at Permalink Reply
jero
According tohttp://php.net/manual/en/datetime.settime.php,... the microseconds parameter was added to the DateTime class in PHP 7.1.0 which would imply that this exception is due to you using PHP 7.1.0 or later. If you were to use PHP 7.0.0 or earlier I believe it would work, because the method signatures would then be identical.

The other option is to use 5.8 instead. Is there a reason you're trying to use an old version of 5.7? (the latest version won't make any difference to your issue)
gwardell replied on at Permalink Reply
gwardell
Hmm, It wold seem PHP should assume zero for that parameter if it's missing.
jero replied on at Permalink Reply
jero
By the way, I'd go with PHP7.0.0 not PH5.6 - it's a lot faster
gwardell replied on at Permalink Reply
gwardell
I am on a Windows 2008 R2 machine. The Web Platform Installer choose 5.7 and PHP 5.6. But I couldn't get 5.6 to run. And I already had 7.1 installed for a WordPerfect site so I choose to use that. I assumed everything wold be upward compatible. And the Concrete installer didn't compline.

So it sounds like my option should be to use a later version of Concrete?
PHP Version 7.1.1
What version of Concrete?

Or, should I try to fix the error?

Gary
Gondwana replied on at Permalink Reply
Gondwana
Recent versions of php are not entirely backward-compatible with their predecessors. One such change is intolerance for missing arguments (as you've observed). That's why you can't run an oldish version of c5 on a newish version of php.
jero replied on at Permalink Reply
jero
You will not be able to get concrete 5.6 to run on anything other than PHP5.x

If you cannot change your PHP version, try using the latest concrete5 version 5.8.3.1 - that should work happily with PHP 7.1
JohntheFish replied on at Permalink Reply
JohntheFish
@mlocati has posted a pull to make 5.6 run on latest php. You would need to build it yourself and its only the core, so addons may also need some work for php7.n compatibility.
weyboat replied on at Permalink Reply
weyboat
I can confirm what @JohntheFish has posted is correct.
I have several sites running on Concrete 5.6 with PHP 7.1.
Yes you will need to sort out the incompatibility issues with your addons but thankfully PHP 7.1 error reporting will indicate what needs fixing and on what parts of the code.
jero replied on at Permalink Reply
jero
Yes, I know, but being on the bleeding edge probably isn't that helpful in this particular case :)

It would be nice if the core team could give @mlocati's updates some attention and make them official - it would be very handy to have 5.6.4 available as an upgrade. Any suggestions on how this can be achieved?
gwardell replied on at Permalink Reply
gwardell
Is version 5.8.3.1 stable?

I am getting a bit muddled.

I took over maintaining a site on a MT server. It is running # concrete5 Version
5.6.3.1 on PHP Version 5.5.9-1ubuntu4.3.

I want to get that running at least on my staging server, and perhaps on my Godaddy Server.

If I put time in I could probably get the older PHP to work, but then is that worth it. I have run into problems where a newer PHP is better, particularly in relation to MySql.

I currently have running PHP Version 7.1.1 on (Windows Server 2008 R2 Standard Edition Service Pack 1). And Concreate5 Version 5.7.5.7 waiting.

So, without going through a lot of gyrations, what is the stable version of concrete that would work in this environment?

Then, how to I move the MT server website into it? I see in the notes something about "You must update to 5.7.5.13 before updating to 8.3.1."

Or do I only need to copy a couple directories and that should work? Oh, and the database?

Gary
gwardell replied on at Permalink Reply 1 Attachment
gwardell
Hi,

Well, I got impatient and put 8.3.1 on and it installed and seems happy.

http://guerrilla-rf.gwsystemsdns.net...

However, it was looking for PHP 5.5.9. See the attached graphic.

So the next step is to transfer a copy of the live site to my staging server.

Any suggestions?

Gary
Gondwana replied on at Permalink Reply
Gondwana
I think that 'requirement' is just misleading. It wants 5.5.9 or better (up to a point). You got a tick; be happy. :)

There's no trivial upgrade route beyond 5.6. There is a tool that can do some of the work, but not custom blocks, etc.
gwardell replied on at Permalink Reply
gwardell
Hi,

I am not sure what you are saying with regard to upgrade.

The live site is Version 5.6.3.1.

Can I move the database and files to my staging server and will it then automatically upgrade those items?

Gary
Gondwana replied on at Permalink Reply
Gondwana
Oh, I see what you're asking, I think.

I'm pretty sure the new system (assuming 5.7+) won't attempt to upgrade a 5.6 database. It just wouldn't work.

The safest route would be to get your legacy and staging servers to the same version of c5 (ie, 5.6.3.1), transfer the files and database, and then progressively upgrade the staging server. Note that the last-mentioned step will involve a traumatic upgrade from 5.6 to 5.7, since there's no automatic upgrade between 5.6 and 5.7.

The php version will need to be aligned with whatever version of c5 you're running at the time (obviously). I suspect that the latest php 5.6 can run all c5s of relevance. When you're up to c5 8 versions, you can move to newer php versions.
gwardell replied on at Permalink Reply
gwardell
So there is no way to upgrade Version 5.6.3.1.

It's basically stuck.

The only way might be rebuilding the website on a newer version.
Gondwana replied on at Permalink Best Answer Reply
Gondwana
That's a bit of an oversimplification. It kinda depends on your site. Have a look at
https://www.concrete5.org/community/forums/customizing_c5/5.6-to-5.7...
and see whether it might work for you.

That's the hardest hurdle to jump, but some caution is required when progressing through other versions. Most intermediate versions can be skipped, but some can't.
gwardell replied on at Permalink Reply
gwardell
This is rearing it's head again.

So, should I try a regular upgrade and see if it works, or will it always fail so I have to use that utility?

Once on 5.7 what is the path up? I get confused reading all of the posts about upgrading.
Gondwana replied on at Permalink Reply
Gondwana
No regular upgrade will get you from 5.6 to 5.7.

If you use the migration add-on thing, I gather you should go straight to 5.7.5.13.

If, however, you have to go via an earlier version of 5.7, be careful of the 5.7.3 dislocation:https://www.concrete5.org/download.... I think you can go 5.7.0/1/2 to 5.7.3 to 5.7.5.13.

From 5.7.5.13, you can jump straight to the latest 8.3 — although the word on the street is that there are some upgrade issues with 8.* which are slated to be fixed in 8.3.3 (so you could go straight from 5.7.5.13 to 8.3.3).

I've never had a problem with upgrades in the 8.* releases, but my sites are simple.

Yes, it's a bit messy, the documentation is somewhat fragmented and confusing, and there are some bugs to sidestep.
gwardell replied on at Permalink Reply
gwardell
So basically I would install the plugin on 5.6. Export everything. Then remove 5.6 and install 5.7.5.13. Then install the plugin thing and import everything and then fix any bugs. Then upgrade to 8.3.3.
Gondwana replied on at Permalink Reply
Gondwana
That's a good summary.

However, I wouldn't remove your 5.6 installation until you've got at least the 5.7 version running fine, given that it will probably be a slow and rocky transition. I'd either run the two installations in parallel on the same server (eg, by installing the 5.7 instance of c5 into a subdirectory), or get the 5.7 version going on a localhost server. The latter would be my preference, if you're comfortable with that sort of setup.

Caveat: I've never used 5.6 nor used the 5.6-to-5.7 upgrade add-ons.

Recommendation: keep backups of files and database before every significant step, and don't delete/overwrite them too zealously.
gwardell replied on at Permalink Reply
gwardell
I am doing this on new server so the old version will still be on the old server.

Reading the comments on the github site I see this:

---
danfyles commented on May 3, 2017

I'm shifting a 5.6.3.4 site to 8.1.0
Was surprised when attempting install of addon_migration_tool_legacy to see that it required version 5.6.3.5b but went ahead and updated to that. Seemed to successfully produce a batch.
But now in my new 8.1.0 install I'm getting alert 'This package requires concrete5 version 8.2.0a1 or greater' when installing addon_migration_tool
---

So it looks like one has to go direct to 8.2 ?
gwardell replied on at Permalink Reply
gwardell
Oh, bother,

Help.

The export says it wants version 5.6.3.5b or greater but I can't find that on the download page.
5.7.0.1 (9-15-2014) - Download
5.7.0 (9-12-2014) - Download
5.6.3.4 (9-11-2015) - Download
5.6.3.3 (2-18-2015) - Download
gwardell replied on at Permalink Reply
gwardell
Hi,

I found it. I stumbled upon it.

I was trying to update to 5.6.3.4 and after downloading that can copying to the updates folder and going to the dashboard to install it, it prompted me to download and install 5.6.3.5.

Now they could have made that a little more obvious.
weyboat replied on at Permalink Reply
weyboat
More obvious?
https://www.concrete5.org/developers/developer-downloads/...
Sixth one down from the top?
gwardell replied on at Permalink Reply
gwardell
Ok,

I see it now. I thought they were ordered numerical.

I got by this

What about my other question about the PATH_INFO error?

It's in another thread.