Installing 5.6.0.2

Permalink
I've been having issues installing 5.6.0.2.

Right now you can see it hanging up on "supports concrete5 request URLs" and "cookies enabled":http://c5.sitetestingserver.com/...

It doesn't provide an error, it just hangs there.

I've had no issues with past installations. Any thoughts?

MichaelG
View Replies:
mhawke replied on at Permalink Reply 1 Attachment
mhawke
I ran your site through Firebug and it is spitting out a 406 error on jquery.cookie.js (see attched screen snippet). I had no idea what a 406 error was so I Googled it and apparently there are some server setups that won't allow jquery.cookie.js to run because it thinks its a cross-site scripting attack. Renaming the file fixes it but that's not really an option for you. This post says your host might have 'Mod_Security' on:

http://www.caiapps.com/406-error-to-retrieve-jquery-cookie-js-file/...

I would contact your host and ask them about it.
jmonroe replied on at Permalink Reply
jmonroe
I think the problem is jquery related too. Some security issue as mhawke described or a jquery clash.

You can also try this for kicks and giggles....

In regards to the Support Concrete5 request URL's error....create a file called php5.ini using text editor. Paste this line cgi.fix_pathinfo = 1

and save the php5.ini file. Once that is done, upload it to the root of your website.

Hope this helps.
mhawke replied on at Permalink Reply
mhawke
You could also try adding this to the end of your .htaccess file in the root of your website. I'm no expert on .htaccess but Google was my friend.

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>
MichaelG replied on at Permalink Reply
MichaelG
I turned of Mod_security and now am good to go.
jmonroe replied on at Permalink Reply
jmonroe
Glad to see your issue is resolved.
emsconcrete replied on at Permalink Reply
emsconcrete
I had the same problem on Inmotion Hosting VPS. Instead of turning off mod_security, I just emailed their support team and asked them to turn off just the mod_security rule associated with jsquery files and cookies. That fixed the problem and is probably safer than turning off all mod_security rules.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I have had this same issue as well. However, it does not matter anyway, since you can simply continue with the installation by using this URL:

hxxp://yoursite.com/index.php/install/-/setup/

From there, the installation process works fine.
rknevhulaudzi replied on at Permalink Reply
rknevhulaudzi
Thanks man,the url worked brilliantly, i struggled with the problem for a day
rknevhulaudzi replied on at Permalink Reply
rknevhulaudzi
Thanks for the post, the url worked well..