Installs fine on server, but kicks back to install page...

Permalink
I am attempting to install C5 on the current host of the mission organization I am with. Everything checked out on the install page (except for Python support) and it installed just fine. However, when I click the link to go to the actual site, it kicks me back to the install page like C5 never installed. However, the database has been populated with 60 tables.

The first time I tried it was a fresh set of files onwww.www.mydomain.com/concrete5....

I deleted and re-created the database, and tried again with the same install files, with the same result.

Does anyone have any ideas why this could be happening?

flywithhim
View Replies:
TravisN replied on at Permalink Reply
TravisN
May be an obvious question, like is the power switched on. But it sounds like the permissions set on the config folder are not correct.

If the server is unable to write the setup files in the config directory it will do as you are describing.
flywithhim replied on at Permalink Reply
flywithhim
I'll check it out.
flywithhim replied on at Permalink Reply
flywithhim
I set the permissions on the concrete5 folder to 777 using FileZilla. Those permissions were inherited to the rest of the folders. Same result on a new database. Is there somewhere I else I need to change permissions?

I also downloaded a fresh copy of Concrete5 and uploaded each file to the server. That didn't help either.

Any other ideas? I'm pretty lost as to why it won't work.

*edit: The permissions on all of the folders in the concrete5 folder are set to 777, and most of the files are set to 666. I set the permissions on concrete5/config/site.php and concrete5/config/site_theme_paths.php to 777.

Same issue. No error messages, C5 just kicks me back to the install page and populates the database.
TravisN replied on at Permalink Reply
TravisN
okay permissions are set. The next thing to look at would be the "site.php" file.

The way concrete5 loads is as follows (shortened version).:
1. check to see if site.php is valid. if not declare $config_check_failed as true.
2. Load default values
3. if $config_check_failed is true then run install

What this means, is your install must be failing the site.php check. What is the contents of this file. It should contain something like:
[code]
<?php
define('DB_SERVER', 'localhost');
define('DB_USERNAME', 'testuser');
define('DB_PASSWORD', 'testpassword');
define('DB_DATABASE', 'test');
define('BASE_URL', 'http://localhost');
define('DIR_REL', '/concrete52');
define('PASSWORD_SALT', 'fiGC8qgxjtRBwAWs7ENKUMILzn9auH5FbyoJlQcpmv6OeXTh12krZ3Y4VDPS0');
?>[code]
flywithhim replied on at Permalink Reply
flywithhim
Except with my server specific info, of course ;)
swp1313 replied on at Permalink Reply
Hi,
I'm hoping to use Concrete5 but have the same problem described here - the install appears to run fine but just returns to the install screen. DB tables are created and site.php looks the same as above so permissions seem to be ok. What was the solution?
Thanks.