Internal Server Error (need fixed fast, HELP)

Permalink 1 user found helpful
Hi I built my customers site before I moved the domain name to the new host... I used http://74.220.219.75/~bloodst2/blog/... But now that I'v moved the site to the real host and I'm using the site name..
http://www.bloodstainsthebook.com/... I'm getting "Internal Server Error" on every page but the main page.

Ive done it this way many times before and never had a problem...but this is my first using Concret5. I don't undersatnd because 74.220.219.75/~bloodst2 is bloodstainsthebook.com?

What do I need to change or reconfigure...and why?

Thanks in advance... I need to fix this fast too, or a client is going to kill me!



Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@bloodstainsthebook.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

View Replies:
jero replied on at Permalink Reply
jero
You may need to adjust site/config.php for the new domain and folder. You should also check .htaccess, particularly if you enabled pretty URLs since the RewriteBase should now be "/".

If you've done that and are still having problems, then you're going to need to find the server error log in order to find out exactly what the 500 error is.
weyboat replied on at Permalink Reply
weyboat
Looks like yout pretty urls setting
Try putting /index.php/ into the url like this
http://www.bloodstainsthebook.com/index.php/excerpt/...

EDIT
It is good practice before moving a site to
Turn Off Pretty URLs
Clear the Cache
Turn off the Cache
Back up the Database
Ghost1 replied on at Permalink Reply
Thanks to you both...You saved my butt. All I did was turn off Pretty URL's and it works fine now. Now I'm a bit gun shy with my clients site, but if I just turn Pretty URL's back on now with the site in it's place will it be ok.... Or should I just leave well enough alone? :)

Thanks again for the help guys!
jero replied on at Permalink Reply
jero
You should find that turning pretty URLs back on will update the .htaccess file. If for any reason it doesn't you may need to paste the code that's shown into the file.

If the wheels do come off, you can always get to the login page at index.php/login, and the dashboard at index.php/dashboard, so you will be able to turn it off again.
ssrgspdkt replied on at Permalink Reply
ssrgspdkt
Hello, Please help me. My sites some pages display 500 internal server error. some pages displays correctly. what can be problem?
vernb replied on at Permalink Reply
vernb
Had the same problem when I uploaded from local server. Made the change you suggested in .htaccess and BINGO ... it worked a treat.
Thanks
Vern