Issue with PATH_INFO on NGINX 1.17 with FPM 7.3

Permalink
Hello everyone,

I'm trying to install a fresh copy of Concrete5 8.x.
Unfortunately, the error message "PATH_INFO" is displayed again and again.

My server setup is:
* NGINX 1.17.x
* PHP-FPM 7.3.x

Here are my current NGINX location blocks:
location / {
        try_files $uri $uri/ /index.php$is_args$args;
    }
    location ~ \.php($|/) {
        try_files $uri =404;
        fastcgi_pass fpm:9000; 
        include /etc/nginx/fastcgi_params;
        fastcgi_index index.php;
        set $script $uri;
        set $path_info "";
        if ($uri ~ "^(.+\.php)(/.+)") {
                set $script $1;
                set $path_info $2;
        }
        fastcgi_param URI $uri;


Even setting
$ _SERVER['PATH_INFO'] = $_SERVER['REQUEST_URI'];

does not work.

In my php.ini I set "cgi.fix_pathinfo=1" and even try to leave "open_basedir" blank.
Nothing seems to work here.

Here some values from the $_SERVER array:
Array
(
    [SCRIPT_FILENAME] => /var/www/index.php
    [PATH_INFO] => /install/select_language
    [URI] => /index.php/install/select_language
    [DOCUMENT_ROOT] => /var/www
    [DOCUMENT_URI] => /index.php/install/select_language
    [REQUEST_URI] => /index.php/install/select_language
    [SCRIPT_NAME] => /index.php
    [PHP_SELF] => /index.php/install/select_language
)


Curiously, an old Concrete5 installation runs with the location blocks shown above. This installation (i think it was version 5.x) is already installed, so that I can not check if the location blocks are still correct for installation.

Can someone please help me out of this problem.

Best,
elpado

elpado
View Replies: