No input file specified on login

Permalink 1 user found helpful
Alright, so I have been trying to fix this for the past two days and I am at my wits end. The website I am working on is mastertraxproductions.com and every things seems to be working correctly except for the login section.

Once you type in the username and password it goes to:
http://mastertraxproductions.com/index.php/login/do_login/...
and the page says, "No input file specified."

I have tried many different .htaccess and php5.ini files (I have attached the two that I am currently using) and I can't seem to get it to go away. Does anybody have any guess or solutions?

Thanks

1 Attachment

View Replies: View Best Answer
JohntheFish replied on at Permalink Reply
JohntheFish
The .htaccess in your attached .zip looks like it is set up for a joomla site, not a C5 site.
monsieurRickman replied on at Permalink Reply
I am fairly certain it is, but I have used it many times before with no issue. I has always worked like a dream for me on GoDaddy Hosting.

I have also tried this code in the .htaccess file

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>


It makes the problem worse. Every page except the home page has the "no input file specified." message. I also tried editing the "RewriteRule ^(.*)$ index.php/$1 [L]" line in various ways as directed by various articles in the C5 Forums but still no luck.
JohntheFish replied on at Permalink Reply
JohntheFish
Appending /index.php/login/do_login/ to one of my C5 paths gets the appropriate response.

http://mastertraxproductions.com/login/do_login/... also gets the appropriate response.

The error message does not appear anywhere inside C5 files, and your other experiments confirm, that it is coming from the server, not from C5.

If you are sure of the .htaccess, I would start looking for other aspects of the server that are different to your other successful sites.

Maybe run phpinfo and compare.
monsieurRickman replied on at Permalink Reply
I looked through some phpInfo and The one thing that I could tell was different as that Session.use_only_cookies is turned off instead of on.

I have no idea if this would cause any problems at all though.
JohntheFish replied on at Permalink Reply
JohntheFish
Personally I still think the most likely cause is something to do with htaccess and rewrites.

Maybe try removing htaccess completely and turning off pretty urls.

Could mod rewrite be turned off? There are multiple tips on the web about ways to test if mod re-write is working. So maybe try one of them.
monsieurRickman replied on at Permalink Reply
I checked several different ways and mod_rewrite is definitely on.

I have used this same .htaccess file on many different sites with godaddy hosting so I don't think that is the problem.

I thought of turning of pretty urls and then turning back on, because that has solved a lot of problems for me in the past but I can't log in to get to the panel. Is there a way to do it manually?

Do you think it really could be the pretty urls doing it? It seems like they are working fine because when you click on about, contact, and services the url is right and it shows the content, but when you log in it goes to thehttp://mastertraxproductions.com/index.php/login/do_login/... page and that's what's broken. and since it has the index.php in the url it shouldn't be relying on pretty urls right?

I just can't seem to figure out why it is throwing that error out only on that page.
JohntheFish replied on at Permalink Reply
JohntheFish
I dont think it is pretty URLs. Its just that the main code in the htaccess is to do with them, so by turning them off you could cut out the htaccess, get things basically working, then move forwards again towards pretty urls and htaccess from there.

The other pages on your menu are directly below the site. Your login response issue is another level down, so maybe that is where the problems are occurring. Maybe you will get a similar error if you try and register.

PS.
http://mastertraxproductions.com/index.php/about... causes the same, whilehttp://mastertraxproductions.com/about... works OK.

Tested on one of my sites, ...domain.com/index.php/about is the same as ...domain.com/about
monsieurRickman replied on at Permalink Reply
Oh good catch! I'll have to fiddle around and see if I can figure out why that is happening.
5fly replied on at Permalink Reply
5fly
Did you solve this one?! I have exactly the same problem with godaddy hosting...
5fly replied on at Permalink Reply
5fly
Just in case anyone is interested...

The simplest fix for this on godaddy hosting anyway.. is to create a new php5.ini in your hosting root and add the cgi.fix_pathinfo = 1

Works a treat!
toitojose replied on at Permalink Reply
Great job!!! it works very well
mnakalay replied on at Permalink Best Answer Reply
mnakalay
Hi,
I had the same problem but on every page except on the index page.

I wrote a tutorial about installing on Godaddy. There you can find the solution I used and it worked for me so maybe it will for you to.
The link to the tutorial ishttp://www.concrete5.org/documentation/how-tos/developers/concrete5...

Good luck
monsieurRickman replied on at Permalink Reply
Thanks, that did fix the errors that I was getting, the only problem that I am having now is that when I log in there is no edit bar. I am looking for a different solution to this problem though.
monsieurRickman replied on at Permalink Reply
I tried multiple fixes to get the edit bar to show up but nothing worked. A lot of the fixes had to do with duplicate javascript or jquery files but as far as I can see there is nothing. The website is mastertraxproductions.com. Any guesses?
5fly replied on at Permalink Reply
5fly
If you can setup a temporary login, I'd be happy to take a quick look!

PM me details if you'd like.
mnakalay replied on at Permalink Reply
mnakalay
It might be the google analytics piece of javascript interfering with the edit bar. Try without it and see if it solves the problem.

If it does solve the problem, you should try to have it appear only when not in edit mode.
monsieurRickman replied on at Permalink Reply
I did notice some forums about how the analytics code caused problems. Unfortunately that isn't the case here. I tried everything I could think of with moving and removing different javascript but nothing seemed to work.
monsieurRickman replied on at Permalink Reply
I had an extra line in my config.php file that was causing the menu bar to not display.

define('SERVER_PATH_VARIABLE', 'REQUEST_URI');


After I removed that everything worked great

A big thank you goes out to mnakalay for helping me out and his tutorial that he posted earlier is top notch.
mnakalay replied on at Permalink Reply
mnakalay
Thanks,
happy I was of some help :)
codaone replied on at Permalink Reply
codaone
I got in to same error but for the solution I couldn't change any php ini settings so had to look for something else. Then I realized that the problem is because of the index.php at the url instantly following by the path (index.php/do_login/). Then I tried to find a way to get rid of the index.php always and found thishttp://www.concrete5.org/community/forums/usage/how-do-i-remove-ind... where it says to set in site.php this define('URL_REWRITING_ALL', true); and voila everything works.