PATH_INFO or ORIG_PATH_INFO

Permalink 2 users found helpful
Hi all,
I have this problem with the installation of the latest release 5.1.1. I've tried to read in the forum and look for some hint, but I haven't found the answer. Could someone help me to install so we (in Italy) can use it with a very wide provider?

here are the links:http://www.galettimotori.it
phpinfo:
http://www.galettimotori.it/info.php...

Thank you
Antonio

sirjohn7x
View Replies: View Best Answer
dotspion replied on at Permalink Reply
I had still the same error and I don't know why so you are not allone but I haven't got a solution.

Now I had the solution for my Webspace I must only place a .htaccess with «AcceptPathInfo On» inside very smart I think :-)
activa replied on at Permalink Reply
Ok, it's stupid, but I had the same problem, chatted with Tech Support who said it looked fine, so I tried another browser and it was ok. Went back to original browser (Opera), cleared my cookies and now it's fine. So try the simple stuff first :/
Ashkirk replied on at Permalink Reply
OMG. Cookies? Seriously? That was my problem too.
Remo replied on at Permalink Reply
Remo
It looks like your provider does not even support PATH_INFO??

Such an url must work on every provider:
http://www.galettimotori.it/info.php/test...
sirjohn7x replied on at Permalink Reply
sirjohn7x
Since I'm forced to use this provider I'm not able to use C5 for this site.. I will have to find another cms
Remo replied on at Permalink Reply
Remo
what kind of provider is this?

a lot of software uses this concept. you also won't be able to use wordpress url rewriting and this is a pretty popular piece of software that should work on every provider's webspace.

I think you should contact your provider about this - send them the url I've posted above. They have to support that..
sirjohn7x replied on at Permalink Reply
sirjohn7x
It's a sh***y provider.. that's what.. now I switched plan to linux since with a test I realized that the ENV is working... Let you know if it's working on it, at least we (in Italy) will know that we can use it
sirjohn7x replied on at Permalink Reply
sirjohn7x
It's working...
so to all italian users you can use ARUBA LINUX plan (the windows plan with CGI PHP is not working) due to this thread problem!
mgood replied on at Permalink Reply
Trying to install Concrete5 for the first time. (XP, PHP5, Apache2) Modified the localization.php as mentioned in the forum. Still does not work. I do get a lot of warnings on the page, and one failed test: Support for C5 Request URLs "Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server."

The install page is full of strict standards warnings, such as: "Non-static method Loader::database() should not be called statically"
andrew replied on at Permalink Reply
andrew
If you are outputting strict errors then that is likely the reason that the PATH_INFO check is failing: the system expects a certain response from an AJAX request and, if there are strict errors printing out in that requested page, it won't be the response that it expects, and the PATH_INFO check will fail.

Try disabling strict errors and see if that gets you through the installation process.
karenalenore replied on at Permalink Reply
karenalenore
Using concrete5.2.0RC1 and getting the same "Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server."

How do you disable strict errors as you suggest? Sorry if that's a silly question.

EDIT: Not sure if that's my problem though b/c i dont have errors on the page besides the installation warning.
ziki replied on at Permalink Reply
Hi, I got the same problem (STRICT warnings and unable to parse PATH_INFO) when trying to install C5 on localhost. It depends on settings of your PHP and apache.

On localhost, the easiest way to solve this is creating a file named .htaccess in the root of c5 and then put following line there:

php_value error_reporting 6143

It will disable the STRICT warnings and also it solved the problem with PATH_INFO
qlex replied on at Permalink Reply
Hi,
ziki: i have tried your solution and added that line to .htaccess in the root of C5 install, and i got:
500 Internal Server Error.

Do you guys have any ideas on how to solve this ?

My safe_mod is turned off, and my phpinfo is here:
www.www.kulesza.net/ztm/info.php...

cheers
qlex
karenalenore replied on at Permalink Reply
karenalenore
to be honest, I gave up and installed apache. Now my computer is slow as snot but at least I'm moving forward. Sorry - don't know what that problem was...
davidgiffon replied on at Permalink Reply
I'm having the same problem.

http://www.ecuriedavidgiffon.fr/concrete5/info.php5...

Could you please guide me here, I have spent 2 days with no results? I would really like to try using this program!!?

Thank you in advance.
davidgiffon replied on at Permalink Reply
I'm having the same problem.

http://www.ecuriedavidgiffon.fr/concrete5/info.php5...

Could you please guide me here, I have spent 2 days with no results? I would really like to try using this program!!?

Thank you in advance.
Remo replied on at Permalink Reply
Remo
Your server doesn't support path_info...

http://www.ecuriedavidgiffon.fr/concrete5/info.php5/testPathInfo...

you must see a variable called PATH_INFO that contains the value testPathInfo. This doesn't happen on your server which means it either doesn't support path_info or it isn't properly configured..
davidgiffon replied on at Permalink Reply
Thank you, I have written to them to find out if they can change this.

I appreciate your speedy response.

dg
davidgiffon replied on at Permalink Reply
Perhaps a stupid question, but...

I am the designer for davidg's website, and he has his site at: ecuriedavidgiffon.fr and I have a server at thewriteimage.ca - Is it possible for me to setup Concrete5 on my server and have him still have his site where he is, and be able to run off my server for the purpose of Concrete5?

Am I making any sense? --I don't think this is possible, but the blonde has to ask...

Seecyd
c/o davidg
stevefister replied on at Permalink Reply
stevefister
Ok, I have the same problem. I've tried every solution I can find. Hosting on the PAID GoDaddy service. Shared Linux environment. Their Help on PATH_INFO says that they run PHP5 as CGI and to use SCRIPT_NAME instead...but that doesn't work either (at least in editing request.php. If there is another file which uses PATH_INFO for the installation check, I'd like to know.

My phpinfo is here:http://watchhilloutfitters.com/phpinfo.php...

Please Helllllp! My customer insisted on using GoDaddy and already bought the hosting for two years...so we're stuck with using it.

Thanks!

<steve>
stevefister replied on at Permalink Reply
stevefister
The install for C5 Request URL support says the following: Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server.

Looking at my phpinfo, it does show a PATH_INFO with value. So I'm thinking that it's not that my server doesn't support it, but that C5 can't "parse" it as the error states. But why wouldn't it be able to parse it if it does indeed exist?
samuelbarney replied on at Permalink Reply
samuelbarney
how did you fix it? steve
Etienne replied on at Permalink Reply
Etienne
Hi!
I have the same problem, i have a paid hosting account on Godaddy (linux plan).
Several people on this forum have the same problem, but i don't find anywhere how solve it.
Please help.

My phpinfo :http://www.espacecrea.com/phpinfo.php...

Thx.
Étienne
frz replied on at Permalink Reply
frz
the problem is that's a pretty common error.. it could be any number of things.. this is like "my car wont start - what's wrong with it???"..

uhh?
Etienne replied on at Permalink Reply
Etienne
Yes i understand, but it's for persons who were in the same situation and have found a solution. I am interested by all of that. And the servers configuration on Godaddy are certainly the same for all (on a Linux web hosted plan).
Thank for your reply.
Etienne.
Etienne replied on at Permalink Reply
Etienne
anyone has an idea? I've tried lot of solutions but nothing run.

Stevefister, I think I'm in exactly in the same situation as you, and I can see now your site running on GoDaddy. If you visit this forum again your help will be appreciated.
brian30 replied on at Permalink Best Answer Reply 1 Attachment
brian30
just add
cgi.fix_pathinfo = 1
to your php5.ini file in your root directory.
For godaddy account only wait 30 minutes clear you cache and try again.
Also don't ever ftp up your files, use godaddys file content manager. Upload it all in zip format and then unarchive it with their tools in the content manager. An example of my php5.ini file would be.

cgi.fix_pathinfo = 1
SMTP = relay-hosting.secureserver.net

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so


This also fixed the
No input file specified.

I've also attached my php5.ini file if you'd like to just download it and use it.
CHMOD IT TO 644.
rajansarc replied on at Permalink Reply
Excellent!
I have the same problem in my GoDaddy shared Hosting. It works great while I put the code "cgi.fix_pathinfo = 1" in php5.ini in the root folder and tried after 30 mins. Thanks for this post.
desmondkuek replied on at Permalink Reply
Thanks Bro. It is worked. ^^^^^^^^^
johndorsay replied on at Permalink Reply
johndorsay
Dude!
thanks so much for this.
This is all I had to do in order to get the site running.
juanzo007 replied on at Permalink Reply
juanzo007
Thanks bro, uploaded that file to my clients Godaddy account, worked like a charm!! Thanks!!
burkie6 replied on at Permalink Reply
thanks for the file, uploding the php5 file did the trick for me
fblondeau replied on at Permalink Reply
Fews tips to help you solve that issue

1 try to acces the install page
if you see somthing before the { or after the } your have a problem

if its a php error try the .htacces fil with display_errors off

In my case our hosting doesn't allow php directive in the .htaccess.

What I did and its not a solution i would recommend in production in the index.php add the following line before the include:
ini_set('display_errors',0);


Thats only a fix that you will have to redo averytime you update you CMS.
Floris replied on at Permalink Reply
Floris
I've got the same problem: on the install-page an error displays saying:

'Concrete cannot parse the PATH_INFO or ORIG_PATH_INFO information provided by your server.'

In the phpinfo sheet the value of 'ORIG_PATH_INFO' is '/info.php'.

I would love to use C5. Does anybody have a suggestion?
nayrangnu replied on at Permalink Reply
I had this problem using MAMP. I fixed it by adding a 'php' directory to MAMP/tmp.
nickratering replied on at Permalink Reply
nickratering
I added some rules to my .htaccess, worked for me so far! (5.4.2)

Options +Includes
SetOutputFilter INCLUDES
AcceptPathInfo On
thephilm replied on at Permalink Reply
thephilm
For many of us, the reason we get this is because there are (strict) errors being displayed. Concrete5 tries to parse the path, but these errors are part of what it's parsing. That doesn't mean the it won't work, we just need to suppress the errors.

I found this to happen when using PHP 5.3+ (tested on 5.3.5)...
You see this especially when running XAMPP or similar on a local setup.

I simply added :
php_flag display_errors off

to the root .htaccess file, and it works fine. Double check if you update your .htaccess file for pretty urls that this directive is still in there.

-Phil
pseeney replied on at Permalink Reply
I have tried all of these solutions, yet still get the same error. What else could be wrong? My client has godaddy hosting, so I am stuck. I followed their manual instal directions to a T, and still get the same errors.
brian30 replied on at Permalink Reply
brian30
Reffer to my godaddy post above and download the file it does work
VishwasG replied on at Permalink Reply
I don't see any php5.ini file in my root. It's only php.ini, and it contains a lot of text ? Where do i find php5.ini then ?
brian30 replied on at Permalink Reply
brian30
the php5.ini is only in reference of godaddy.com hosting..you simply download the attachment above and upload it. Please read my above post closely.
ryuzaki01 replied on at Permalink Reply
Options +Includes
SetOutputFilter INCLUDES
AcceptPathInfo On


thanks..
this one works for me !!