PHP 7.3 and 7.2 with C5 8.5.1+

Permalink
Had an interesting install problem where C5 8.5.1 would not install with PHP 7.2.10 but would do an install with PHP 7.3.9
With PHP 7.3.9 C5 would not install any extenstions etc with errors pointing to the zip extension and timeouts etc.
Switch back to PHP 7.2.10 and system SEEMS to run fine.
The other thing I found was that I had to increase execution time to max of 120 seconds.
Is C5 fully compatible with PHP 7.2 once installed or is there still issues?
If so would I be better to put PHP 7.1 as an option on the server for others who wish to update their C5 sites to the later versions as I have heard of a few concerns on the forums with 7.2 and 7.3
Where moving away from PHP5, and allow PHP 7.1 and up.
PHP 7.3 on centos 7.6 is giving us a couple of issues with the odd extension for PHP - namely the ZIP. Thats another issue that we should be able to sort soon.
We' hoping to switch a number of C5 sites to the new dedicated server and also update all the the latest software where possible.

View Replies: