php7.2 and package incompatibilities

Hi all,
Trying to upgrade a CC5 site (Version 8.5.1) to run under PHP 7.2 and keep getting a 500 error. I'm guessing it's one of the packages causing the error though I'm not sure how to debug this since the error isn't recorded anywhere when it happens since I get a blank 500 error page.

Anyone have a suggestion on how to debug this?

View Replies: View Best Answer
lukasznillo replied on at Permalink Reply
Hi. Check server PHP error log. This in many cases showed me what the problem was.
growlrooed replied on at Permalink Reply
Thanks for the info!
growlrooed replied on at Permalink Reply
Hi, I just looked over the logs and found the following. (i stripped out some of the sensitive server info here.)

PHP Fatal error: Uncaught PDOException: could not find driver in /public_html/updates/concrete5-8.5.1/concrete/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43:

which on looking that code:

public function __construct($dsn, $user = null, $password = null, array $options = null)
try {
parent::__construct($dsn, $user, $password, $options);
$this->setAttribute(PDO::ATTR_STATEMENT_CLASS, array('Doctrine\DBAL\Driver\PDOStatement', array()));
} catch (\PDOException $exception) {
throw new PDOException($exception);

See anything out of the normal?
Gondwana replied on at Permalink Best Answer Reply
Make sure that the relevant PDO php extensions have been enabled on your server. You maybe able to do this via CPanel or equivalent; if not, it's a job for your host.

My installation has PDO, PDO_MYSQL and PDO_SQLITE active. I doubt you need the latter.
ConcreteOwl replied on at Permalink Reply
@Gondwana is correct about the PHP Extensions.
I just turned off pdo_mysql and the same error you are reporting popped up for me.
So check them as @Gondwana has suggested.
Incidentally turning off the pdo_sqlite did not throw an error.
growlrooed replied on at Permalink Reply
Thanks Folks! I'm checking with the webhost right now.

Installing those PDO extensions worked like a charm. Thanks again.