Problems updating 5.5.2.1

Permalink
Im having problems updating from 5.5.2.1... First, the database backup function is not working, i only get blank page when using backup function. However i downloaded my database by Php My Admin and also whole puplic_html folder. Second, when im trying to update to 5.6.3.5 (this is what concrete offers in update section) i get Internal server error. Uploading the original config/site.php fixes this error. I tried to manually update to 5.7.3 by uploading the package to /updates but the updatepackage i not visible in update section in Dashboard. Also clicking Check for updates in Dashboard gives me following error:

Warning: Cannot modify header information - headers already sent by (output started at /home/vanhaonk/public_html/concrete/controllers/dashboard/system/backup_restore/update.php:57) in /home/vanhaonk/public_html/concrete/libraries/controller.php on line 356

What should i do?

View Replies:
hutman replied on at Permalink Reply
hutman
You can not upgrade to 5.7+ from 5.5, there is no upgrade path.

However, you can upgrade to 5.6.3.5, but it's going to take a few steps. I would suggest using thishttps://legacy-documentation.concrete5.org/tutorials/manually-upgrad... article and method 2.

Your upgrade path will need to be 5.6.0, 5.6.3, 5.6.3.5. You have to do all of those steps for a successful upgrade (in my experience).
Onslow replied on at Permalink Reply
Still Internal server error when trying to run upgrade...
hutman replied on at Permalink Reply
hutman
Depending on your server settings this could be an issue with the max_execution_time, can you bump that up a bunch and try again?
Onslow replied on at Permalink Reply
I noticed that i dont even have to launch the update, it gives me Internal server error same time i put new /concrete folder to use...
hutman replied on at Permalink Reply
hutman
Yes, you have to run the update before the server 500 error will go away after replacing the /concrete folder.
Onslow replied on at Permalink Reply
Ok, max_execution_time is set to 30, im not able to change that so i need to contact my host... What value would be correct?
hutman replied on at Permalink Reply
hutman
If you can get it set to 300 temporarily that should do it, it can be put back after the upgrades
Onslow replied on at Permalink Reply
Ok, i tried with value 300, still Server error...
Onslow replied on at Permalink Reply
Any ideas...?
hutman replied on at Permalink Reply
hutman
What is the error you are getting if you check your server's PHP error logs? If it's still the running out of memory error you either need to make the number higher, or when you changed it the change didn't take affect.
melange replied on at Permalink Reply
melange
Hi all,

Thanks heaps for jumping on board with this post. I may have found a solution. This is mostly the response I got from my hosting provider.

"Hello,
Thank you for contacting DreamHost support. You are getting the error
about �Fatal error: Out of memory (allocated�.� because your site is has
run out of allocated php memory. You will need to allocate more for the
site. You will need to create a custom php.ini file for the user then
adjust the file settings in that file. Custom PHP settings are beyond the
scope of our support, for full instructions can here:

Overview:https://help.dreamhost.com/hc/en-us/articles/214200688...

For creation via ftp:
https://help.dreamhost.com/hc/en-us/articles/214894037...
For creation via SSH:
https://help.dreamhost.com/hc/en-us/articles/214200668...

If your site keeps hitting the memory limit, you might want to verify
your site is optimized or upgrade to a vps."

Ill try and get that sorted once I work out using a FTP .

Thanks again Ill update if not the solution for this forum post
melange replied on at Permalink Reply
melange
lol classic

Not even my question but the header question was basically like one I asked recently

Sorry ignore
Onslow replied on at Permalink Reply
There isnt any errors visible in cPanel Errors section. Is this because of C5's own error logging? In error_log file found in public_html the last notice is from 2014, and i dont get any new notices even if i broke my theme on purpose to get syntax error. So this is not working correctly, right? I tried to switch off and back on the error loggin in dashboard but no effect...

EDIT: i noticed that in C5 dashbord it says max_execution_time is 5 and cPanel says its 90.
hutman replied on at Permalink Reply
hutman
These errors would never go into the Concrete5 log, nor would any of the Concrete5 settings change the server's error log.

I would suggest you ask your host where PHP Errors go, if they are logged.
Onslow replied on at Permalink Reply
It seems that this just isnt goint to be solved this way... I asked my host about the error loggin and they said Concrete is somehow blocking cPanel own error logging, which seems to be the case since i looked into several sites im hosting and which is using Concrete, and none of them shoved any errors in their cPanel. Is it possible to delete current version of C5 from server, install latest version and make it use the old database?
Onslow replied on at Permalink Reply
I finally managed to update this to 5.6.3.5. All i did was this:

1. Deleted all content from server
2. Installed fresh 5.5.2.1 and made it use my old database
3. Upgraded to 5.6.3.5 which seem to be last "automatic" update before 5.7

Now i have problem with installing finnish language package, after i choose it from control panel, Concrete says i need to log out and in to make it affect, i get the following error:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 291338 bytes) in /home/vanhaonk/public_html/updates/concrete5.6.3.5_remote_updater/concrete/libraries/3rdparty/Zend/Cache/Backend/File.php on line 962