remove index.php from the url

Permalink
Hello!

i'm new in the Concrete5 World and test the CMS. At the momemt, it looks good and is easy to use.
It is possible to remove the index.php from the URL. i can set this in the system settings
but when i activate this, some subpages are not reachable any more and i get a error message
"url not found on this server" for example when i try to logout "/login/do_logout/xxxx"

does anywone have the same problem?
is there a solution for this available?

i use the latest version of concrete5

thank you in advanced for your help

View Replies:
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Try clearing the cache...
Whilst you are developing your site you should tun off all caches.
e4u replied on at Permalink Reply
Hello

thank you for your hint, but it doesn't work .. i've the same problem.

any further ideas?
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
can you post the content of your htaccess file (found in the root of your site)
e4u replied on at Permalink Reply
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>

this would be added automaticly by concrete
e4u replied on at Permalink Reply
I found the error. it was on the webserver himself.
at the vhosts settings you have to allow the override

<Directory "/var/www/html/samplepage">
AllowOverride all <---
# Allow open access:
Require all granted
</Directory>
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Well done!