Switching to Pretty URLs

Permalink
I've read a few posts previously, that switching to Pretty URLs can cause major issues with a Concrete5 site... What do I need to do to make things go as smoothly as possible, and if something goes wrong, how do I get it back? Basically, all I want to do is remove index.php from the URLs.

Thank you - newbie question. :)

View Replies:
rge replied on at Permalink Reply
If activating pretty URL's is causing major issues this will probably be related to the configuration of the server. For a smooth experience, I advise using the dashboard settings page. If you run into issues you can "easily" undo the changes.

You can remove index.php from the URL via the dashboard
yoursite.com/index.php/dashboard/system/seo/urls

Check "Remove index.php from URLs" and save. If your write permissions are setup correctly a .htaccess file should have been created. If this is not the case you can create one yourself and add the following rules.
<IfModule mod_rewrite.c>
   RewriteEngine On
   RewriteBase /
   RewriteCond %{REQUEST_FILENAME} !-f
   RewriteCond %{REQUEST_FILENAME}/index.html !-f
   RewriteCond %{REQUEST_FILENAME}/index.php !-f
   RewriteRule . index.php [L]
</IfModule>

The .htaccess file should be placed in the root.

Seo config rules are added in the Concrete config file located in application/config/generated_overrides/concrete.php.
'seo' => [
    'redirect_to_canonical_url' => 0,
    'url_rewriting' => true,
]


So if you want to remove these settings and you are for some reason unable to do it via the dashboard you can follow these steps.

1. Remove the rewrite rules in .htaccess
2. remove the SEO rules in the config file