TimeoutException (1000)

Permalink
Hi
I've just installed v8.5.1 on Ubuntu 18 with 4GB memory.
When I try to login to edit, I get a TimeoutException (1000) error.
Any ideas how I can solve this would be much appreciated.
Thanks
Muziquerete

View Replies: View Best Answer
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
I have found that if the login redirect is using the default setting (DESKTOP) that it significantly slows down the login process.
To change this manually go to application/config/generated_overrides/concrete.php and around line 19 you should see
'login_redirect' => 'DESKTOP',

Change it to...
'login_redirect' => 'HOMEPAGE',

Just ignore the message at the top of this page that states 'DO NOT EDIT THIS FILE DIRECTLY' since you are able to amend it in the dashboard.
muziquerete replied on at Permalink Reply
Hi there ConcreteOwl,
Thanks for that. It did the trick.
It's not encouraging to meet this kind of screen, the first time you open a new piece of software.
Is there anything important on the welcome screen, and if I can't get it to load, can I access the same information elsewhere?
ConcreteOwl replied on at Permalink Best Answer Reply
ConcreteOwl
If you want to view the 'Welcome Screen', when logged in, directly below the 'Dashboard' you will see 'Welcome' click that and wait for the page to load.
Your not missing much though...
muziquerete replied on at Permalink Reply
Thanks again.
I can't get that page to load at all, so I'll just have to take your word for it.
I wonder what causes it to time out. The server has 4GB of memory and it has plenty of free memory.
It would be useful to be able to see it.
Today I found this:
https://documentation.concrete5.org/tutorials/disable-welcome-screen...
ConcreteOwl replied on at Permalink Reply 1 Attachment
ConcreteOwl
Currently it looks like the attached screenshot.