Ugrade - host went to php 7.2 - I upgraded Concrete5 to 8.5.2 - web throwing error - how to fix?

Permalink 1 user found helpful
After host upgraded to php 7.2 my website broke - I upgraded Concrete5 to 8.5.2 - now getting the error below - when trying to access website. I can get to the administrator console, but cannot get my website to display. I am not a programmer - am a tech (engineering retired). What exactly needs editing? I tried finding the lines in the code stated below - but then did not know exactly how to edit to stop the problem? HELP Can someone tell me what needs to be added ? ($, "", etc to what) Thanks Helene

Whoops \ Exception \ ErrorException (E_WARNING)
Use of undefined constant CACHE_LIFETIME - assumed 'CACHE_LIFETIME' (this will throw an Error in a future version of PHP)

Whoops\Exception\ErrorException thrown with message "Use of undefined constant CACHE_LIFETIME - assumed 'CACHE_LIFETIME' (this will throw an Error in a future version of PHP)" Stacktrace: #45 Whoops\Exception\ErrorException in /home/helros4/ #44 ReflectionClass:newInstanceArgs in /home/helros4/ #43 Illuminate\Container\Container:build in /home/helros4/ #42 Concrete\Core\Application\Application:build in /home/helros4/ #41 Concrete\Core\Entity\Block\BlockType\BlockType:loadController in /home/helros4/ #40 Concrete\Core\Block\BlockType\BlockType:getByID in /home/helros4/ #39 Concrete\Core\Block\Block:getByID in /home/helros4/ #38 Concrete\Core\Page\Collection\Collection:getBlocks in /home/helros4/ #37 Concrete\Core\Area\Area:getAreaBlocks in /home/helros4/ #36 Concrete\Core\Area\Area:load in /home/helros4/ #35 Concrete\Core\Area\Area:getAreaBlocksArray in /home/helros4/ #34 Concrete\Block\CoreAreaLayout\Controller:setupCacheSettings in /home/helros4/ #33 Concrete\Block\CoreAreaLayout\Controller:cacheBlockOutput in /home/helros4/ #32 Concrete\Core\Block\CacheSettings:get in /home/helros4/ #31 Concrete\Core\Block\Block:getBlockCacheSettingsObject in /home/helros4/ #30 Concrete\Core\Block\Block:cacheBlockOutput in /home/helros4/ #29 Concrete\Core\Block\View\BlockView:useBlockCache in /home/helros4/ #28 Concrete\Core\Block\View\BlockView:runControllerTask in /home/helros4/ #27 Concrete\Core\Block\View\BlockView:setupRender in /home/helros4/ #26 Concrete\Core\View\AbstractView:render in /home/helros4/ #25 Concrete\Core\Area\Area:display in /home/helros4/ #24 include in /home/helros4/ #23 Concrete\Core\View\View:inc in /home/helros4/ #22 include in /home/helros4/ #21 Concrete\Core\View\View:renderTemplate in /home/helros4/ #20 Concrete\Core\View\View:renderViewContents in /home/helros4/ #19 Concrete\Core\View\AbstractView:render in /home/helros4/ #18 Concrete\Core\Http\ResponseFactory:view in /home/helros4/ #17 Concrete\Core\Http\ResponseFactory:controller in /home/helros4/ #16 Concrete\Core\Http\ResponseFactory:collection in /home/helros4/ #15 Concrete\Core\Http\DefaultDispatcher:handleDispatch in /home/helros4/ #14 Concrete\Core\Http\DefaultDispatcher:dispatch in /home/helros4/ #13 Concrete\Core\Http\Middleware\DispatcherDelegate:next in /home/helros4/ #12 Concrete\Core\Http\Middleware\ThumbnailMiddleware:process in /home/helros4/ #11 Concrete\Core\Http\Middleware\MiddlewareDelegate:next in /home/helros4/ #10 Concrete\Core\Http\Middleware\FrameOptionsMiddleware:process in /home/helros4/ #9 Concrete\Core\Http\Middleware\MiddlewareDelegate:next in /home/helros4/ #8 Concrete\Core\Http\Middleware\CookieMiddleware:process in /home/helros4/ #7 Concrete\Core\Http\Middleware\MiddlewareDelegate:next in /home/helros4/ #6 Concrete\Core\Http\Middleware\ApplicationMiddleware:process in /home/helros4/ #5 Concrete\Core\Http\Middleware\MiddlewareDelegate:next in /home/helros4/ #4 Concrete\Core\Http\Middleware\MiddlewareStack:process in /home/helros4/ #3 Concrete\Core\Http\DefaultServer:handleRequest in /home/helros4/ #2 Concrete\Core\Foundation\Runtime\Run\DefaultRunner:run in /home/helros4/ #1 Concrete\Core\Foundation\Runtime\DefaultRuntime:run in /home/helros4/ #0 require in /home/helros4/ COPY
Stack frames (46)

View Replies:
hutman replied on at Permalink Reply
Search the application/blocks and the packages directories for CACHE_LIFETIME and you will probably find something like this

protected $btCacheBlockOutputLifetime = CACHE_LIFETIME;

in a block controller, just remove that line and it should fix the problem.
Petersewell replied on at Permalink Reply
This worked for me.

I found the block controller which caused my problem and it was in TWEET-FEED-PACKAGE.

I used ubuntu's GREP command to search a download of all of my website looking for the exact wording you listed above and I found the file and deleted the line and all is working.

Thank you