Uploaded from local and only a blank screen!!

Permalink
Mike/Anybody,

I've followed Mikes uploading instructions. I set up a new remote database and uploaded the local one no problem.

I have configured the site.php file as instructed which now looks like this:

<?php
define('DB_SERVER', 'localhost');
define('DB_USERNAME', 'web171-igrieves');
define('DB_PASSWORD', 'rosebury');
define('DB_DATABASE', 'web171-igrieves');
define('BASE_URL', 'http://www.oxeyes.org');
define('DIR_REL','');
define('PASSWORD_SALT', 'BUNOQ9YbvqM7LcpTRIDftwA7gW2taC4KR4whLLgEqznTeABgRgHi7cOe7Y92DpiH');
define('PERMISSIONS_MODEL', 'advanced');
?>

It mirrors the site.php file on a succesful remote C5 installation I did to test C5 (except DB usernname and password obviously)

When I access my site:http://www.oxeyes.org all i get is a blank screen ( previous tries had got 'can't connect to database' at least!)

I have re uploaded all the C5 files just in case.

Any ideas please???

Ian

igrieves
View Replies:
aowslimited replied on at Permalink Reply
aowslimited
hmmm if i try to view your source i don't see any files.

1. check that your host supports the use of localhost for db connect name
2. check that there are no spaces in your index.php
3. try removing the line
<define('PERMISSIONS_MODEL', 'advanced');


thanks
dan
igrieves replied on at Permalink Reply
igrieves
Dan,

Thanks for getting back to me. In response

1.yes my host does support localhost - it worked with my test system

2. what do you mean - no spaces in my index.php? The only code on the page is:

<?php
require('concrete/dispatcher.php');

3. I removed the permissions model line - no change.

Interestingly I cant see any source code on the index.php page when I try to view it live. This seems to indicate the page is not being read? If I load an html index page I can read that however!

So far no progress!!

Any more thoughts?

Ian
Mnkras replied on at Permalink Reply
Mnkras
#1 once you put the Advanced permission model line in your site.php do not remove it,

#2 i can see the site fine...
igrieves replied on at Permalink Reply
igrieves
Dear MnKras,

I've deleted the site and re installed it from scratch so yes you can see it!!

Btw there is a line on the main set up page:
http://www.concrete5.org/documentation/installation/installing_conc...

where it tells you about installing advanced permissions. The line has an error:

<?php define('PERMISSIONS_MODEL', 'advanced'); ?>

The last ?> is not needed. When you use this line of code the site does not show. Remove it and it does. The line on the Permissions page is:

<?php define('PERMISSIONS_MODEL', 'advanced');

Hope this is of use.

Otherwise thanks for a great product and great support from the members, I have been very impressed, keep up the good work and I hope I can be of use to the newbs one day!!! Ian
jasteele123 replied on at Permalink Reply
jasteele123
FYI, there is nothing wrong with the instructions.

You simply had something after the closing ?>

Space, tab, newline, etc.

Same thing will happen if you have any before the opening <?php tag in most any PHP file.

Thought this might help somebody else down the line.

Johnhttp://www.steelesoftconsulting.com/...
saltman replied on at Permalink Reply
saltman
From my knowledge of php if you leave out the ending delimiter ?> the php parser will add the ending delimiter. This is why leaving out the ?> worked, but is not good practice. I will at times highlight the area up to the ending delimiter and then type back in the ?> to make sure no hidden characters are present.

Cheers
godbrain replied on at Permalink Reply
godbrain
I was just looking here but please tell me that wasn't your real login information in that post. :D
igrieves replied on at Permalink Reply
igrieves
It was indeed. Been deleted now of course! Thanks for your concern.