Can't add any more sub pages

Permalink
I'm working on a concrete5 website running version 5.6.4.0. The site admin with administrator privileges can no long add any more sub pages beneath a certain node. They have around 100 sub pages beneath this page in question...

Logged in as super user, there is no issue - sub pages can be added fine.

I've done some digging in the code and located the config value 'SITEMAP_PAGES_LIMIT'. This was set to 100 by default so I thought I'd found the culprit. I set this to 200 in the site.php file using the below code
define('SITEMAP_PAGES_LIMIT', 200);

However, to my dismay this has not resolved the issue...

Has anyone else found they can not add more than 100 sub pages and if so, is there a way around this?

c5hub
View Replies:
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
The config value for SITEMAP_PAGES_LIMIT simply limits the number of sub pages that can be viewed in a folder of the sitemap, a kind of pagination for sub pages.
To test this, set it to 5 and then look in your sitemap folders, you will see what I mean.
I cannot find a permissions limit for creating new sub pages anywhere in the code?
Maybe look at workflows waiting for the user or even a large amount of database dross causing issues.
Try signing in as the user to see if it could be user error..
c5hub replied on at Permalink Reply
c5hub
Yes, I think you're right.

After a deeper dive in to the code this afternoon, I too was struggling to see anywhere in the code that specifically limits adding pages at a certain number.

It must have been coincidence that the SITEMAP_PAGES_LIMIT so happens to be around the same number that the issue starts.

The only permission based thing I can find that appears to reference any such potential functionality is canAddSubpages

There is a reference to this in the sitemap.js file, which would appear to hide both the 'Add Page' and 'Add External Link' options - which is the case here.

What is even more odd, is that this is NOT a problem for superuser and it only happens when trying to add a sub page to a node that already have 90+ sub pages.

It works as intended both adding pages to the top level and beneath other nodes with less sub pages.

This leads be to believe it is not a database issue.

It's definitely an odd one and not something I've come across in the 10 years + I've been building concrete5 websites.
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Anything showing in the browser console when this happens?
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
This is a long shot and you may have already had a look at it...
In the sitemap check the permissions for that node, click on Add Sub Page permissions then click the 'Details' tab and see if the Administrators Group is allowed to add All Page types, if it is set to 'Custom' this could be your problem..
c5hub replied on at Permalink Reply
c5hub
I'm only running basic permissions, so this is not an option.

The only console error that appears is:
GET /dashboard/sitemap/full/None 404 (Not Found)

This actually is present on all the other 5.6.4.0 sites I've checked too. Don't think it is related.

Appreciate your help - this is a very strange issue with no obvious resolution.

I just tried adding a page outside of that parent. then tried to drag it in to taht sub section and got the following:

"You do not have sufficient privileges to add this page or these pages to this destination."

So something does seem off with the permissions/privileges...

I'm going to spend some more time today digging through the code.
c5hub replied on at Permalink Reply
c5hub
OK, so I logged in as the administrator and loaded up the 'Properties' for the parent page. I made a small change and then reverted and saved again.

It now looks like I can add sub pages again as administrator.

It seems that maybe there was some odd permissions issue in that maybe the parent page was edited by the super user and then this stopped the administrator from being able to add any pages beneath...

It is still very strange, as there are other pages that have sub pages created by super user but can still be added to by a regular administrator.
ConcreteOwl replied on at Permalink Reply
ConcreteOwl
Hmm
Possibly the parent page required approval for an incomplete edit and thus prevented more sub pages from being added.
A strange one indeed..