File Manager

Permalink
I've seen a lot of messages describing this same problem, but everything they suggest doesn't seem to help.

When I try to upload a file, I get an error message : "Unable to copy file to storage directory. Please check permissions on your upload directory and ensure they can be written to by your web server."

I've tried every variation of permission setting possible, recursively. 775 ... 777 ... 755. It doesn't seem to matter. I still get nowhere.

When I try to upload to the /incoming with an ftp client, and then try to add incoming, I get an error that says "You must select at least one file," even though I do have a file selected.

I am not running php in safe mode, and my php_error.log and my httpd error logs don't show any errors related to this.

Finally, to test to see if my permissions settings are correct, I tried copying a file I already have in my file manager, and I seem to be able to duplicate the files with no trouble at all.

I read somewhere that deleting the cache might help, but I got similar errors when I tried to do it through the interface, and my client's website stopped displaying correctly when I did it manually, so I restored from a backup.

I'm getting very frustrated. Can anyone please help me? Thanks in advance.

View Replies:
mohammedfaqruddin replied on at Permalink Reply
Hi there,

Can you try this -> Go to dashboard/system & settings/ Under the "Environment" section, click on "File Storage Locations" and check the path to your files folder is correct.
GreatWork replied on at Permalink Reply
Yes. The file path appears to be correct.
weyboat replied on at Permalink Reply
weyboat
Advice deleted since OP did not respond.
GreatWork replied on at Permalink Reply
I'm sorry. I expected to get an email when I received a reply to this thread, and none came.
weyboat replied on at Permalink Reply
weyboat
The URL of the site in question
What version of Concrete are you using
What version of PHP is your host running
How big is the database file (export it from phpMyAdmin)
GreatWork replied on at Permalink Reply
www.powderhornagency.com
# concrete5 Version 5.6.3.1
Current PHP version: 5.4.162.0
sql file is 44.7 MB
weyboat replied on at Permalink Reply 1 Attachment
weyboat
Attempted to view your website and was blocked?
See the attached image
GreatWork replied on at Permalink Reply
Not sure why your net admin is blocking stuff, but I'm pretty certain that's on your end, not mine.
Gondwana replied on at Permalink Reply
Gondwana
Nope. I get the same response. Your site/server is geo-locked.
weyboat replied on at Permalink Reply
weyboat
Thanks @Gondwana for confirming this!
GreatWork replied on at Permalink Reply
Ok. Well, I have no idea why the client admin would do such a thing, but thanks anyway for your time.