Advanced permissions not taking effect

Permalink
Hi all,

I'm hoping this is a simple case of checking an option, but I can't figure it out after many hours trying, so thought it best to record what I'm doing and see if there's anything obvious wrong.

I'm trying out advanced permissions for an upcoming client who wants authors to be able to edit content and publishers to be able to approve versions.

However, what I'm trying to do at this point is restrict their access to the dashboard / admin as I would using normal permissions (which works by the way). This is a clean install and I've only being using advanced permissions so far. I've also since tried setting access settings in Sitemap, File manager and Sitewide Settings to see if it helps, but no luck so far.

So watch the video and let me know if it's something easy I'm overlooking please.

Thanks,

Osu

1 Attachment

osu
View Replies:
nige replied on at Permalink Reply
nige
Hi Osu.

I have just been doing this and it seems to work in not the most obvious way. Iw as going to say logical but it is logical when you think about it.

Add your group to the dashboard permissions dialog and check READ. Check nothing else. This will save. If you dont check anything it wont save. (dunno why)

Turn on show system pages if you cant see the dashboard page.

Set the pages to inherit and straight away youve hidden half your dashboard.

Once youve done this you can play about with extra yes and nos with sub pages etc but I think this will work.

Nige
osu replied on at Permalink Reply
osu
Hi Nige,

Thanks for the suggestion, but unfortunately that's not working for me - what version of C5 are you using?

I've attached a screenshot of my settings for the homepage and also the dashboard.

Homepage (won't let me embed the image for some reason):

http://img4.glowfoto.com/images/2010/06/18-0714088810L.gif...

Dashboard:

http://img4.glowfoto.com/images/2010/06/18-0711214232L.gif...

Cheers,

Osu
osu replied on at Permalink Reply
osu
Can someone from the C5 team confirm whether this is a bug, or something I'm overlooking please? I'm trying this on a clean install so it's not to do with any addons.

Thanks
ryan replied on at Permalink Reply 1 Attachment
ryan
What groups is that 'author' user in?

Also, You need to pull the read permission from the guest group for the dashboard. It should look something like the attached screenshot.
osu replied on at Permalink Reply
osu
Hi Ryan,

Thanks for getting back to me. After fiddling about a bit more, I realised that a manual setting further down the sitemap was causing problems.

For anyone having the same problems, here's what I did: When I 'reset' all the permissions (i.e. removed all the manual permission settings on subpages of the dashboard), things starting working as they should:

Home (manual):
Authors (read / write)
Publishers (read / versions / write / approve / delete)

Dashboard (manual):
Authors (read / write)
Publishers (read / versions / write / approve / delete)

I set the Dashboard to manual so that all subpages below this inherit permissions from the Dashboard page instead of Home (which I think was the problem).

Then I changed permissions to manual on pages like Reports, Users & Groups etc. and removed both the Authors and Publishers groups because I didn't want these users to see those pages.

This seemed to work for me.

Thanks,

Osu