All of my changes dissapeared when I added a canonical url.

Permalink
wow! I just discovered that I have an Apache Config problem caused by when I set a canonical url while trying to get pretty urls working. When I did that, it caused my web site to revert back to the original Elemental theme without any of my work in it. All this time I thought it was a problem I was having with c5-8 because all my work was still in the site folders and files but from that point on nothing that I did was materializing in the web site folders. I never considered that I had set up another running install of c5-8 in my default virtual website. I now have to figure out why adding the conical url of my web site would cause Apache not want to serve up the requested site. I feel soo stupid but I am old and at 72, I can use my age as an excuse for stupidity.

p.s. Accepting any suggestions as to why Apache would vomit with the canonical url addition and what c5-8 does with the canonical url and what url should be placed in this field and when and why.

ThomasJ
View Replies:
jasteele12 replied on at Permalink Reply
jasteele12
See my reply from the original thread.

You are not posting any useful information to try and help you...
ThomasJ replied on at Permalink Reply
ThomasJ
>>How did you install the theme?
The theme was installed with the c5-8.3.2 installation. It was the default theme.

>>Can you share the website address URL
http://www.k9homefinders.org. This is now serving up the virtual default web site and I put that c5 into maintenance mode.

>>I have no idea what you mean by "set up another running install of c5".
When running Apache as a virtual host service, the first virtual web site loaded into Apache is used as a default in case of any reason the requested web site is not found. Usually one would put an informational index.html to for a Site Not Found display page. I happened to install a whole c5-8 web site there instead when I first set up the new server and forgot about that.

>>Can you post a copy of your .htaccess file
This is the one that c5 creates for you when you turn on pretty urls:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /concrete/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
>>You can always manually include /index.php/ in your testing in your browser location.
Yes. The pages are accessible when manually inserting /index.php/ into the url. A 404 error is rendered up when links are clicked on. Also, I did set the .conf file to "AllowOverride All".

>>If you are developing a site, make sure that you have all caching disabled!
All caching is disabled.
jasteele12 replied on at Permalink Reply
jasteele12
Clonemental is not part of the core, and a key part of your original post.

There is no real point in sharing a URL to a site in maintenance mode.

The .htaccess looks fine. My guess is you have messed something up in your Apache configuration.

What exactly did you put into the Canonical URL and SSL URL fields?
ThomasJ replied on at Permalink Reply
ThomasJ
I think you are confused about my issue. I am running a virtual hosting environment and my Apache service is hosting multiple web sites. The problem is when I added a canonical url into the pretty urls settings, my Apache server quit seeing my configuration for the web site in question and is now serving up the default web site's web pages instead. I have the default site set to maintenance, not the site that should be displayed. If I can figure out what caused the server to start malfunctioning and fix it, the correct web site should start to be rendered again. Right now, it's broke.
I enteredhttp://www.k9homefinders.org
ThomasJ replied on at Permalink Reply
ThomasJ
p.s. I installed Cloneamental after this issue started. The reason I found out that the site that was being served up was the default web site is because that's where I found the Cloneamental package and not in k9homefinders.
ThomasJ replied on at Permalink Reply
ThomasJ
What is incredible is that I am going through my htmld logs now and there are no errors indicating why Apache doesn't like my k9homefinders.conf file.
ThomasJ replied on at Permalink Reply
ThomasJ
OKAY! Back working again.
I'm sorry for this post. Although I still have c5 problems to fix as a result of all my trial-n-error working on this issue. It turns out to have been caused by a couple of omissions in my Apache config files. What I overlooked is that I started to use the domain name with the www. prefix and I didn't have an alias set for this. while I was requesting the website correctly all was fine. I had also left out the NameVirtualHost declaration that binds the vhosts to the ip:port and as a result of that, instead of getting the obvious browser error for not finding the requested site, Apache served up the hard wired default site.

Also, I also came up with the cause of pretty urls not working. In the httpd _website_err log, I found this; "Options FollowSymLinks and SymLinksIfOwnerMatch are both off, so the RewriteRule directive is also forbidden due to its similar ability to circumvent directory restrictions". So, I added "Option FollowSymLinks" to my .conf and now the .htaccess overrides are working.