Allowed memory size of 134217728 bytes exhausted (tried to allocate 12288 bytes)

Permalink
Hello,

I am constantly getting this error message when navigating to only one of my pages. I have cleared cache many times and cannot visit the page without getting an error. Please help.

Kindly,
Athan

1 Attachment

View Replies: View Best Answer
shahroq replied on at Permalink Best Answer Reply
shahroq
Hi,
Increasing the PHP "memory_limit" in your server php.ini file should resolve this. The default value is usually 128M. This can be increased to 256M.
AthanD replied on at Permalink Reply
Hello,

Thank you for your reply. I have tried looking for a php.ini file but i don't think I have one. The is nothing in CGI-Bin. Is there code i can add to the index.php in my public_html folder?

Kindly,
Athan
katalysis replied on at Permalink Reply
katalysis
The error seems to refer to the GD image processor php module.

Is there a chance you have an overly large image on that page that the server is struggling to process?

If so you could replace it with a smaller image via the File Manager.
AthanD replied on at Permalink Reply
Hello,

Thank you for your response.
I have removed all large files in file manager but still cannot get onto the page. Is there anything else i could try?

Kindy,
Athan
AthanD replied on at Permalink Reply
*SOLVED*
Increasing my memory limit in php selector options in cpanel has solved the issue.

Thank you for the responses.

Athan
chawilaclef replied on at Permalink Reply
chawilaclef
Comes from a too big data display.
Could be a var_dump() somewhere, or a for() loop with a too big limit.
Or an object with too many fields.
Remember every blocks you have on this page.
Crearte a new empty page and drop thoses blocks and test when you have this bug again.
So you will know what blocks it comes from.