Auto nav appears twice

Permalink 2 users found helpful
hi,

I encouter a matter with the autonav, it appears twice time ...
I don't understand because when I'm logged in admin mod, the autonav displays correctly.
But it don't work for guests...
i've tried to clear cache in Dashboard and Browser.
the website :http://www.becsa.fr
Does someone have an idea ?

thx in advance.

View Replies: View Best Answer
irsah replied on at Permalink Reply
irsah
Hai,

Your page source appears two navigation (the autonav) *slight correction there.

Can you check in Dashboard > Stacks > Global Section > click Nav Header and see is there duplicate there?

Hope it helps.
Irsah.
Asgatlat replied on at Permalink Reply
i know that in the source code, the autonav appears twice...
when i'm logged in admin mode, the autonav doesn't appear twice in the source.

i've checked the Stack in Dashboard, it's not duplicated.

may i missed something... :s
irsah replied on at Permalink Best Answer Reply
irsah
What I meant, the codes appeared twice (in firebug) but in chrome browser page source only appeared once. Sorry I was passing by.

It's probably cache, I had this issues many times when my cache settinng is checked or turned on. You can turn off all cache-ing, try that if you have not.

Or manually clear/delete the cache files in your_path_to_domain/files/cache/ folder.

In addition, the other Nav is tucked in your image/logo, it's in that block. try and check that area. Temporary disable the image/logo block and see what happens.

Hope it helps.
Asgatlat replied on at Permalink Reply 1 Attachment
seems better, but now i've a strange bug :
my index page in edit mode began messy...
i've try to restore the previous version and if i approuved it, the home page begin like the screenshot (see the file)
i've tried to copy another page to rebuild the index page but i can't success...
how to restore it ?
Asgatlat replied on at Permalink Reply
no ot's ok it seems to work
the cache was the problem, thx for your help :)
irsah replied on at Permalink Reply
irsah
If you've deleted the cache files it is re-building again. It needs to be saved to the newest version first by visiting the page to let it be stored to he newest approved version rendering.

If you've preview before the approval, it will show an unsaved cache image of you page, that is why it looks un-arranged. Somehow you must approve that current version and let cache save the newest updated view of your page.

You can also marked this thread helpful to close it so others can find the answers to the same problems occured. No problem, your welcome. Glad to help out.
Asgatlat replied on at Permalink Reply
my website crashed...
i've just add the html code
<br clear="all" /></div>
between the auto nav and the slideshow and now all my page are like the screenshot...
i've tried to enable the cache in dashboard but still same
irsah replied on at Permalink Reply
irsah
No you have an addition </div> in your logo/image.. delete that extra </div>... check all your closing div's as well..

<br class="clear" /> with trailing slash already closes it self..
Asgatlat replied on at Permalink Reply
right !

thanks a lot for all :)
irsah replied on at Permalink Reply
irsah
and also make sure your code <br class="clear" /> with a space before the slash.. manage to look thru with limited source and saw 3 or 4 similar codes on your site. at header, before closing body and footer.