Bold, Italics and Strikethrough not working

Permalink 3 users found helpful
Hi,

Bold, Italics and Strikethrough is not working in wysiwyg editor. Sometimes it works but most of times it does not. Can anyone please help?

Thanks in advance!
Mohammed

View Replies: View Best Answer
MrKDilkington replied on at Permalink Best Answer Reply 1 Attachment
MrKDilkington
Hi mohammedfaqruddin,

Are you experiencing this issue when using Chrome?

If so, there is a bug in Chrome that breaks Redactor in concrete5 5.7. While users wait for a new version of Chrome, there is a fix by community member mlocati that you can use.

[5.7] Fix Redactor issue with Chrome 58 #5425
https://github.com/concrete5/concrete5/pull/5425...

I have attached a ZIP file with a copy of redactor.js that has the fix applied.

Steps to use the fix:
1. locate the redactor.js file
concrete\js\redactor.js
2. rename the file from "redactor.js" to "redactor.js.original"
3. unzip the attached ZIP file to the concrete\js directory
concrete\js\redactor.js
4. clear your browser cache
mohammedfaqruddin replied on at Permalink Reply
Hi MrK,

This worked. Thank you!

Regards,
Mohammed
webpresso replied on at Permalink Reply
webpresso
Many thanks for the clear steps.
That helped a lot for bold/italic etc.

------------------------------------------------------------------------------------
There seems to be another issue with copy and pasting in redactor. This happens on feature block. Or on blocks we created with block designer.
After placing the cursor somewhere the pasted text is always added on the top of the text and not in the right position.
Bogi28 replied on at Permalink Reply
Thanks guys for help i had same problem. :D
MrKDilkington replied on at Permalink Reply
MrKDilkington
@webpresso

What you are describing sounds like a new Chrome bug.
https://github.com/concrete5/concrete5/issues/5929...
webpresso replied on at Permalink Reply
webpresso
Yes. Looks exactly like this!
Chrouglas replied on at Permalink Reply
Hey all. I am at my whit's end. This should no longer be an issue correct? I am still not able to use the italic, bold, strike in the redactor. I cant even get the custom styles to apply.

I've tried removing the custom styles just in case that was the issue.

I've applied the chrome_browser_fix_redactor.zip fix.

I've updated to 5.7.5.13

I've tried removing my css and JS files from the pages.

I've tried switching the theme to elemental.

Is there something I am not doing? Works great in FF just not in chrome.

Thanks all.
C
MrKDilkington replied on at Permalink Reply
MrKDilkington
@Chrouglas

Using the fix, Redactor is working correctly in the latest Chrome.

I would make sure to clear your concrete5 cache and do a "Empty Cache and Hard Reload".
https://superuser.com/questions/220179/how-can-i-do-a-cache-refresh-...
Chrouglas replied on at Permalink Reply
Strange. I did try it in incognito. and just now did the cache clear and browser hard reload. This site shares a core with a couple of other sites via a symlink so I also tried it on another site (also 5.7.5.13 but with its own core). The other site is on the same server and it too did not allow the italic/bold thing.

Could it be a server thing? Any ideas?
MrKDilkington replied on at Permalink Reply
MrKDilkington
@Chrouglas

With Chrome developer tools open, did you try checking "Disable cache", then refresh?
Chrouglas replied on at Permalink Reply
Ugh. Installed a fresh copy of 5.7.5.13 with the redactor fix on a different server and it worked fine. Will try a fresh copy on the suspect server and let you know. Weird.