Error adding Express Address field (Exception occurred...)

Permalink 2 users found helpful
Concrete 8.3.1

error is: An exception occurred while executing 'SELECT t0.akDefaultCountry AS akDefaultCountry_1, t0.akHasCustomCountries AS akHasCustomCountries_2, t0.customCountries AS customCountries_3, t0.akGeolocateCountry AS akGeolocateCountry_4, t0.akID AS akID_5 FROM atAddressSettings t0 WHERE t0.akID = ?' with params [57]: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't0.akGeolocateCountry' in 'field list'

To reproduce the error (reliably)
1. System / Express / Add Object
2. In new Entity page, fill out some Entity Details
3. In Attributes tab, create new entity, type Address
a. leave all Address Options at default
b. click Add

Go to

View Replies:
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi bobhy,

Using the steps you provided, I was unable to reproduce the issue.
aschaffer replied on at Permalink Reply
I am also experiencing this. Perhaps something got messed up in the update because I do not have a column called akGeolocateCountry in my db
aschaffer replied on at Permalink Reply
This can be solved by Refreshing Database Entities at the following page:

YOUR_SITE/index.php/dashboard/system/environment/entities/view
JeffPaetkau replied on at Permalink Reply
This worked for me
PixelFields replied on at Permalink Reply
PixelFields
Also had this error but on member and profile single pages after upgrading to 8.3.1; refreshed entities but error message changed to:
array_flip(): Can only flip STRING and INTEGER values!

Any ideas? Thanks in advance!