Internet Explorer Crashing/Close and Reopen the Tab

Permalink
I've recently been asked to make some changes to a site someone else created using Concrete5. Before making any changes to the site I took a backup of the database and copied all files down from the ftp site. After doing this, but before making any changes myself to the site, I noticed I got the message 'a problem with this website caused internet explorer to close and reopen the tab' in Internet Explorer. I thought it was a one off so ignored it and proceeded to make several changes to the website. The customer has since also got in touch to say they have had the same problem with the website in IE, it firstly says Internet Explorer has stopped working, then gives the message 'a problem with this website caused internet explorer to close and reopen the tab'. He hadn't noticed this issue previously so I'm not sure what change caused this issue with the site (his daughter has also been adding some text and images recently). If you Google the website and click the page link, any page link, you also get the same problem so it is not just the home page. There's no problem at all with either Google Chrome or Firefox. Any suggestions either what might be causing this (I've Googled the problem but the answer it suggests is that something is wrong with your Internet Explorer and to try resetting it, but this does not explain why it is a problem on my customers browser also, he has tried on both his home and work computer) or suggestions of websites or programs that can analyse the website to help determine what's wrong? The website in question is lisamariesboutique.co.uk.
View Replies:
lambiv replied on at Permalink Reply
Still not having much luck with this one. I went through all of the code on the website and removed anything I thought could be causing this problem. Now, when I type in the domain name I no longer get the message about the tab being closed and reopened. However, when I search for the website on Google I still get this message. Also, when I try and access the site from favourites I still get the message. I've noticed though that if I save a new copy in favourites and access this then I do not have the problem. The only difference I can see is that the title is now different, otherwise the webpage names are the same, would this cause a problem with internet explorer? The same would be true for Google, it is referencing an old copy of the pages with an old title as it has not recently crawled the site.

This makes no sense, am thinking the best plan is to just start the site again from scratch!
Mnkras replied on at Permalink Reply
Mnkras
try clearing out your browser cache, I have never seen this specific issue, what version of internet explorer are you using aswell?
lambiv replied on at Permalink Reply
I've never seen the issue before either and there doesn't seem to be an easy answer on Google (the answer I keep finding is that the problem is my computer, not the website, which doesn't explain why we are getting the same issue on several computers). I've cleared my internet explorer cache, cleared the site cache and even got Google to clear the cached results but still have the problem (although Google has not crawled the site recently so is still displaying an old title for the page, which is why I thought this may be the cause of the problem?). Likewise for the old pages saved in favorites, the page name is the same but title different, could this really cause an issue? To change the title I simply went to 'Properties', 'Custom attributes' then added a meta title, is there another file I should have changed as well that could result in an issue?
lambiv replied on at Permalink Reply
I'm using Internet Explorer 8, with Windows Vista. My customer has Internet Explorer 8 with Windows XP.
Chairmonkey replied on at Permalink Reply
I'm having the same issue as well. The page crashes on Interent Explorer 8 as soon as the page tries to load. It happens when downloading assets. What version of C5 are you using and are you using any plugins or themes on the page? This is a big hiccup for me, as the client would like to launch tomorrow and there's no way we can do that without IE working.
JohntheFish replied on at Permalink Reply
JohntheFish
Is this on a live site on a server, or on a wamp development environment? If the later, it could be the development environment that is giving trouble.
lambiv replied on at Permalink Reply
Not sure what version of C5 it is, how do I check? They have used 'Sortable Fancybox Gallery - 1.14', 'Galleria image gallery - 2.0',
and 'Tweetcrete - 1.6.0', although I've removed the last two from the site. The guys who created the site made up a theme of their own.

From what I've figured since posting this, the issue is specific to Internet Explorer 8 and compatibility mode, which was introduced with internet explorer 8. The customer also mentioned that he had just installed IE8 when he started seeing the problem.

If you go to 'page' then 'compatibility view settings' and select 'display all websites in compatibility view' then this removes the problem, IE no longer crashes when I search for the site in Google, so I assume this is what the problem is. Finding out what's wrong with the site to cause the issue is not so easy though. I've run the site throughhttp://validator.w3.org/ to check the code is all good, I had to fix a couple of issues (and also remove Tweetcrete) but my now 'valid' pages still cause this problem. I ran a similar css validator and turns out there are several issues with the site, mostly resulting from the template the guys created and none that are a quick fix. There are several suggestions on the web for ways to force compatibility mode for your website (adding code to the head of each page etc.), I tried a couple but they didn't make a difference.
JohntheFish replied on at Permalink Reply
JohntheFish
You can see the environment through:
/dashboard/system/environment/info/

However, looks like you are on a live site, so my previous suggestion is no longer applicable.

If you were in Chrome or Firefox, I would say 'look at the developer console'.

You could argue that the reason for compatibility mode is to enable sites to be viewed in IE when IE crashes out.

You say "IE no longer crashes ..... search in Google", so are you sure it is the site, and not Google that IE is struggling with?
lambiv replied on at Permalink Reply
No problems with Chrome or Firefox, only IE. IE combined with Google it would seem, which doesn't seem to make any sense. If I type the domain in directly in IE then I don't get this issue. If I search on Yahoo then I don't get this issue. But if I search on Google then I get this message every time, no matter which page link I click. If I search on Google on Chrome or Firefox, I do not get this issue. So something between IE and Google is the problem....
jero replied on at Permalink Reply
jero
Me too - I am having an intermittent problem with XP/IE8 (but not IE7) or Win7/IE8/9.

I believe it's due to the "advanced slider" addon - although reporting it to the developer hasn't been much help. Same problem on 4 PCs in our house - none of which use IE on a regular basis (you *will* use Firefox, children) so unlikely to be flaky addons etc.

Only seems to be WinXP and IE8. Removing the advanced slider block and everything is happy. But boring! ;)
jero replied on at Permalink Reply
jero
I think I found a fix yesterday - I found that if I make sure that my template looks like this:

<head>
<?php Loader::element('header_required'); ?>


I.e. the element is loaded *directly* after the html <head> tag, the problem went away. I had a couple of CSS links in there before. Seems explorer can't hack it, but other browsers work fine, and the w3c validator was also happy.