No Save / Cancel button in WYSIWYG editor

Permalink 1 user found helpful
This is a strange one. The person who updates the website reported this issue but I am unable to recreate.

In edit mode, there are no Save / Cancel buttons (see photo). There are errors in the Chrome developer console. (see photo).

Prior to troubleshooting, caches were cleared on the website and all browsers.

The issue is consistent across pages of the website. It is consistent between browsers (Safari / Chrome) and computers (Mac / Windows 7).

I am unable to recreate the issue on Windows 10 (IE, Chrome) or Ubuntu (Chrome).

I have seen past problems about a misplaced <div> or improper loading of Jquery in a theme. However, I haven't made any changes to the theme or any shared elements of the website. Only content within blocks has been edited via the WYSIWYG editor since I migrated the site from 5.6 to 8.4.4 one month ago. I am using clonamental theme with minor modifications to rearrange some blocks.

Addons Installed:
PDF Viewer v.1.0.1
Spacer v.1.0.1
Cloneamental v.0.9.3
Simple Gallery v.1.0.7
Migration Tool v.0.9.0

2 Attachments

View Replies: View Best Answer
mnakalay replied on at Permalink Reply
mnakalay
I saw that "unexpected token <" error before and every time it was because of a package trying to load resources from the package's on_start() function. But of the packages you listed, none of them is doing that. So it might be something else or maybe when you modified Cloneamental you modified the package's controller?

It would be interesting to know more about the other error, the 409 error. Could you expand the error by clicking on the arrow next to it and take another screenshot?

Alternatively feel free to shoot me a private message and I can have a quick look for you if you want.
yrrah replied on at Permalink Reply 1 Attachment
The expanded arrows aren't very helpful (attached).

Tried incognito mode in chrome to ensure no browser addons were conflicting with Jquery, but the same error happens.

I'm still unable to recreate the situation on my computers. It's almost as if something is corrupted and cached near one ISP and not the other.
yrrah replied on at Permalink Best Answer Reply
We found a solution (sort of). The person editing the website installed a VPN, cleared caches, etc. Now everything functions normally, as I was seeing it all along. So somehow a Jquery file was not being served by their ISP.