No Tools in Toolbar

Permalink
On many/most pages, the toolbar's tools are missing. Why?

I'm also getting this error:

An unexpected error occurred.

Allowed memory size of 94371840 bytes exhausted (tried to allocate 16384 bytes)

1 Attachment

View Replies: View Best Answer
Gondwana replied on at Permalink Reply
Gondwana
Probably a javascript error. Check your browser's debug console.
jero replied on at Permalink Best Answer Reply
jero
Turn on debug in the dashboard
/index.php/dashboard/system/environment/debug
enable Show the debug error output

Save, and then try again. You should get a more informative error output which will tell you what's causing the problem.

It may also be a huge image which is too big for the image processing routines to handle. 94371840 bytes is only 90 megabytes, which is not really very much. If you can, set you memory_limit in php.ini or .user.ini to 256MB. You can also check what memory_limit is set to by going to dashboard, system/settings Environment information. If it's less than 256MB you're probably going to struggle.
Gondwana replied on at Permalink Reply
Gondwana
You're probably right. "An unexpected error occurred" does sound more like a php problem.
jero replied on at Permalink Reply
jero
On the contrary - concrete5 is merely showing a generic error. Turning on debug will show a more detailed one which will help isolate the problem.
Gondwana replied on at Permalink Reply
Gondwana
I'm trying to agree! :) I think that generic message indicates that c5 has caught a php error rather than a javascript error, which was my first reaction.
jero replied on at Permalink Reply
jero
LOL. Good to be on the same page :)
doccarter replied on at Permalink Reply
I think you may be onto something with the memory limit. Mine is set to "90M."

Sorry if this is a stupid question, but how do I fix this? In other words, where would I find php.ini or .user.ini?

Thanks!
jero replied on at Permalink Reply
jero
You would drop them into your root of your website, the same one that contains concrete ,packages etc. Which one is used depends on how your PHP installation is configured. Both would be plain text files containing the line

memory_limit = 256M

You could also upload a php file, e.g. phpinfo.php containing this
<?php
phpinfo();
?>


and then access it in your browser. Amongst the information it reveals, it should show you which configuration files are in use.

Remember .user.ini has a dot at the beginning,
doccarter replied on at Permalink Reply
It worked! It worked! It worked! Oh thank you so much!!!!!

I figured it out that the file is called phprc and is located in the PHP version # folder. (I'm on Dreamhost if that means anything.)

Oddly, the update initially applied to one site but not to the other, even though they both use the same phprc file. The memory limit error (and missing tools in toolbar) continued to display only on the home page of the site that did NOT update.

After a few minutes, angels sang and suddenly the home page refreshed with (1) no error message, (2) all available tools, and (3) interestingly enough, the page content I'd forgotten was there suddenly reappeared. I went back to the dashboard and verified that, sure enough, the memory_limit now shows 256M. Hurray hurray hurray hurray!

Thank you thank you thank you thank you thank you !!!!!
jero replied on at Permalink Reply
jero
Glad you got it sorted, but do calm down - you'll pop a blood vessel!

:)
doccarter replied on at Permalink Reply
You have no idea what a tremendous relief it is to solve this. I have been TRYING to get these sites up and running for almost two years with no luck. Haven't been able to get anything to work right. I thought Concrete5 was simply not usable. But then . . . lo and behold it turns out the problem is Dreamhost's default memory_limit setting!

Thanks again!