Not working - help!

Permalink
Hi, have set up a search function for searching our news section. I have created the new page for search results, with a search block - this works if done by itself. I have also setup the search block on the original page and set it to show results on the other page - but I get this message "No page could be found at this address" but the page exists and can be accessed in other ways. When the search block is altered to display results on the original news page, this works fine.

Any idea why this isn't working?!?

View Replies:
madeforspace replied on at Permalink Reply
madeforspace
My guess is that it may be something to do with the page name you are redirecting the results to. Does where you are redirecting to have the same URL as in the page properties for the page? Are pretty URL's on?

Just a suggestion, hope it helps.
scottburton replied on at Permalink Reply
The URL is correct.

What are 'pretty URLs'?
scottburton replied on at Permalink Reply
Ok, so I've found out about pretty URLs and checked our website - we are enabled for pretty URLs. So that doesn't answer my issues.

Thanks for suggesting.

Anyone got another idea?
madeforspace replied on at Permalink Reply 1 Attachment
madeforspace
Sorry it was not the correct solution.
Just in case I have attached a screen print of one of my functioning Search boxes, you never know something may be different.

Anyone else got any ideas?
scottburton replied on at Permalink Reply
The link you have there is '/index.php/search'

Can I ask?
- why is there no 'http://' etc before '/index'?
- should my link also miss out the start of the full address?
- should mine have '/index.php'?

The link I was using is:
http://www.southeastscotlandscouts.org.uk/resources/news-search-res...

This is the URL that can be found in the properties for the page (via dashboard).

I also tried missing out 'http://' but it didn't work.

I also tried:
http://www.southeastscotlandscouts.org.uk/index.php/news-search-res...
But again it didn't work.

Sigh.
12345j replied on at Permalink Reply
12345j
Make sure you've indexed all your pages
scottburton replied on at Permalink Reply
What does that mean or look like?
12345j replied on at Permalink Reply
12345j
Dashboard system and maintenance
scottburton replied on at Permalink Reply
Went to Dashboard and Maintenance. Clicked 'run checked' which then generated a statement of "Index updated. 80 pages required reindexing" but then tried to search again and it didn't work.

Any more ideas?
madeforspace replied on at Permalink Reply
madeforspace
I guess you fixed it, I see a working search :)
scottburton replied on at Permalink Reply
Not quite. It works in the sense that it displays results on the same page, but I cannot get it to display on my search results page.
12345j replied on at Permalink Reply
12345j
just a question. as this ever worked or only when you upgraded to 5.4.1 has it stopped?
12345j replied on at Permalink Reply
12345j
I just made a new page called search, and then redirect to search, not /search or index.php/search. Also, make sure you have the correct page location, and aren't typing in space search or something like that.
scottburton replied on at Permalink Reply
We got it working last night. Seems that we needed to shorten the link to

'../resources/news-search-results/'