Site can't be updated at all. Help!

Permalink
Hi, I can't update my site in any way. When I try to, for example, edit some text in the content editor, I get an Error box with a load of writing in red, it starts like this but there's loads of it:
$(function() { var ccm_menuObj4866 = {}; ccm_menuObj4866.type = "BLOCK"; ccm_menuObj4866.arHandle = 'Banner'; ccm_menuObj4866.aID = 66; ccm_menuObj4866.bID = 48; ccm_menuObj4866.cID = 80; ccm_menuObj4866.canWrite =true; ccm_menuObj4866.hasEditDialog = true; ccm_menuObj4866.btName = "Advanced Slider"; ccm_menuObj4866.width = 550; ccm_menuObj4866.height = 570;

The site still displays okay but can't be updated. Also, if I try to update any meta info a huge vertical error that far taller than my screen appears and the only way of getting rid of it is force quitting the browser. Please see attached.

Any ideas very welcome.
Thanks.

1 Attachment

View Replies:
johnpaulb replied on at Permalink Reply
johnpaulb
Hello DanK,

Have you checked your file permissions? Here are common settings:
Folders - 755
Files are typically - 644

If you use cPanel this article may help:
http://www.webhostinghub.com/support/website/how-tos/how-do-i-chang...

Cheers,
John-Paul
DanK replied on at Permalink Reply
Thanks John Paul, do you have any idea what particular folders I should be looking at checking? Do my error relate to any particular file or folder area?

I selected Command-I on the 'files' directory about 10 minutes ago to see what permissions it was reporting and it's still not giving an answer.

Thanks again.
DanK replied on at Permalink Reply
Someone suggested on another thread changing /files /config and /files to 775 which I have done via cpanel as ftp seemed to be going nowhere. Still no change though.

Do the file permissions changes need to be done recursively to change not just the folder names but all of the contents within them?

I'm lost... Any suggestions really welcome.
DanK replied on at Permalink Reply
This is strange, to me at least. I had added a 301 Rewrite to the.htaccess file in order to hide stop google indexing both the homepage at rood level and the index.php page. I removed the below line and it's working fine.

RewriteCond %{THE_REQUEST} ^.*/index.php
RewriteRule ^(.*)index.php$http://www.domain.com/$1 [R=301,L]

Thanks for the help anyway.