Unable to connect to database

Permalink
Hi there,

This is really odd. I upgraded last night to the last stable C5 version 5.5.2.1. It worked fine before going to bed.

I checked the my web this morning and found:

Unable to connect to database.
A database error occurred while processing this request.

If it worked before... why does it not connect to the database now??

This is my first upgrade and I would also like to know what happens with the old directory concrete folders? Does C5 upgrade run from the updates folder? Last night was working from there...





Please help!

ggutierrez79
View Replies: View Best Answer
triplei replied on at Permalink Best Answer Reply
triplei
the first thing I would do is take a look at your config/site.php file to make sure everything in there still looks correct.

You'll probably notice a line in there referring to the folder which the update is running from at the very end of the file. During the update process concrete5 updates this file to point to the updated copy of core which sites in the updates/ folder.